WiFi Dongle

Soon after I got my Endpoint I tried the WiFi sample program included in the documentation using a WiFI dongle I had used on a Raspberry Pi clone. It did not work.

After reading the documentation, I noticed that dongles using the RTL8188 chipset were required, so I ordered one from Amazon. It arrived today.

The dongle with the correct chipset worked. Imagine that…

I have not done any serious testing yet, but using the .Net Ping class I was able to ping ghielectorics.com.

A link to the WiFi dongle on Amazon is below. On sale for $3.50.
https://www.amazon.com/dp/B008O2AL0K?psc=1&ref=ppx_yo2ov_dt_b_product_details

I hope to do some more WiFi tests later…

4 Likes

Could you share to us the one you use on Raspberry Pi that don’t work?

Most likely the dongle did not work because it did not use the supported chipset.

I think this is a common feature of dongles. The RTL8188 chipset is also the only one I have Debian drivers for, and I need to compile it to work with the pocket beagle (and family). Perhaps GHI ported the driver as well? If so, then I believe my EDIMAX Dongles would also work. Going to be a while before I can test, sadly.
https://www.amazon.com/gp/product/B00FW6T36Y/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

1 Like

Is there a recommended dongle we can get? what about a list of those that GHI tested with and found to be stable?

The dongle should use the RTL8188 chipset.

Options

I used a TP Link dongle to test

TP-Link USB WiFi Adapter for PC(TL-WN725N), N150 Wireless Network Adapter for Desktop - Nano Size WiFi Dongle for Windows 11/10/7/8/8.1/XP/ Mac OS 10.9-10.15 Linux Kernel 2.6.18-4.4.3, 2.4GHz Only : Amazon.ca: Electronics

Mike reported that this works good

Amazon.com: Netis WF2120 Wireless N150 Nano USB Dongle, Ideal for Raspberry, Windows, Mac OS, Linux, RTL8188CUS, Plug in and Forget : Electronics

@Dat_Tran - I placed the above dongle info. into the docs.

Please review →
Update Endpoint/sbc.md with list of reported Wi-Fi dongles by rcmb · Pull Request #753 · ghi-electronics/Documentation (github.com)

Nice thanks.

This one works, from amazon.ca:

Edimax Wi-Fi 4 802.11n Adapter for PC - New Version - Wireless N150 Nano USB Adapter Dongle, 150Mbps, Smallest Wi-Fi 4 Dongle, Windows, Mac OS, Linux, Black, EW-7811Un V2

I’m not 100% sure, but if it’s not working, try hot swapping it in and out when the board is up and running?