Where is the dual in USB Dual Power module?

I’ve tried several transformers and jacks, with 7 and 9 volt DC power, but I can’t get any of them to work with the USB Dual Power module for the Fez Spider .NET Gadgeteer Kit. I also seen questions online about this. How do you make it work? Also tried it on several DP modules.

Welcome to the forum!

Can you please describe your setup in more details? How are your modules connected, etc?

The dual means the Spider can be powered via USB or an external power supply via the power jack.

When you say it is not working, what is happening (or not happening)?

Is the LED on lite the USB power module?

What happens when you use the USB cable and plug into a PC?

How exactly are you hooking up the power supplies?

Everything works fine with the USB connection to a computer, but I’ve tried connecting to the other jack with transformer output of 7 and 9 volts DC, and it either doesn’t make the connection, or something doesn’t work in the circuit. I’ve tried several jacks and transformers.

On your transformer, is plus the inner hole and the outside shield is negative? You probably have negative polarity, see the image http://www.ghielectronics.com/images/catalog/280-3_large.jpg

Thanks! I reversed the leads and it works.

I’m having major issues with this DP module. Reverse polarity is not my case.

What I am seeing is this:
-Power from laptop USB, no problem, device loads and runs app fine
-Power from 7VDC in 2.1mm jack, proper polarity, 700mA, power LED on DP module and gadgeteer are lit, app does NOT load or run, also will NOT talk to VS if still connected to PD
-Power from external battery in USB port, power LED on DP module and gadgeteer are lit, app does NOT load or run

What the heck???

Other notes:
-If the T35 screen is plugged in, normally it shows default text on boot of gadgeteer, but with EITHER external power types plugged into the DP module, it literally lights the WHOLE screen up white, blanks out the text. WEIRD.

-Battery used is Monoprice Portable Mobile Charger, part 7661, Products no longer Available

What am I doing wrong?

DP module works at 7V but not anything under. My guess is that 7V is drooping below 7V. Use a 12V power pack and you should be good to go.

Good point Gus, that could be it. I will snag a better supply today.

However, can you shed light on the USB side? I mean, its only getting 5v from the USB connector from the laptop. Why would the 5v from the battery not work? Did I make a bad assumption trying to “hijack” the mini USB input power as opposed to 2.1mm jack in that case?

I just tried 9V, no luck. :frowning:

Can you tell us about your power supply, what the 700ma was and what current the 9v one is capable of? not all supplies are equal.

Also, check the actual voltage of your 9V battery. Even brand new 9V batteries are more like 8.5V and that drops fairly quick. If it’s been used even a little then you’re probably still back in that marginal territory.

7v and 9v at 700mA was insufficient. 12v 1A did the trick. FYI for anyone else caught with “odd issues”, try full power. :slight_smile:

Remaining Question:
What is the expected behavior when both the 12v 2.1mm external power is connected, as well as the 5v USB to the PC? What I am getting is similar to described earlier - complete system freeze. Screen (T35 if connected) goes fritz, and app fails to load or talk to VS. This means I cannot debug apps while connected to external power, only when connect to USB/PC, which means I cant run all my heavy power modules at once. :frowning: The device runs my code fine once deployed and running on external power only.

screens suck power, I can understand how 700mA is not enough and 1000mA was needed…

The expectation should be that the external power supply powers the complete hardware solution, and the USB is debug-only. (I don’t have a DP to check though !) It would seem to me that this is the exact scenario most people will want, when they have lots of peripherals.

Exactly my expectation. Therefore confused as to why my device locks up when both my 12v and my USB are connected, but not either/or.

Steps to repro:

  1. plug in 12v power to 2.1mm
  2. plug device into USB

Result = driver load failure (gadgeteer is not visible to PC)

Try also:

  1. plug device into USB (driver loads, device is visible to PC)
  2. plug in 12v external power (driver drops out, no longer visible to PC)
  3. [em]unplug[/em] 12v external power (driver re-loads, device visible to PC again!)


Not seeing how I can possibly debug a device while its on external power.

simple test. Can you rip all your hungry peripherals off again and try debugging with the 12v power in the DP module? My bet: it will work. What does that show? Possibly that even 1A isn’t cutting the mustard in your use scenario.

Good test Brett, you might be on to something. But I’m still confused.

[ul]I unplugged everything but an LED, ran app just fine with external power + USB debugger
I plugged in a music module, also ran everything fine
I plugged in a SD card, app crashed, driver dropped[/ul]

Call me crazy, but these just don’t seem like high power modules. The modules mentioned are hooked up, but not even used. I have 12v 1A (power brick from my power hungry Netgear Router).

And please also note: the device operates just fine off the 500mA USB from PC [em]alone[/em], or the 12v 1A power supply [em]alone[/em], but when together… poof, crash!

Check all your solder joints on the DP module and make sure there aren’t any shorts. Sounds like a DP module issue. Do you happen to have another DP module you can test?