Where is GHIElectronics.TinyCLR.Devies.USBHost

I’m trying to implement a file system with a mass storage USB device on SCM20260. I can’t find it on NuGet ???

You have preview 6 downloaded?

Will do. But dont see it on NuGet

Has preview 6 been released? Not in download section of documention.

Fat finger?

haha! Sorry I meant preview 5

Don’t see 5 either


Can you please clarify whether you looked? We want to make sure it is clear for everyone.

If I can find it anyone can!


looked only on NuGet. The downloads page does have it. However, when I upgraded to preview 4, I ended up have to copy all source to a new project. Is there a best sequence of updating?

All nuggets are still preview and not posted in NuGet.org yet

Updated everything to preview 5. Updated the firmware on the 20260.
Tried it on a simple solution. Updated the project references to preview 5. It ran fine

Did the same thing on the pre production solution that has multiple projects. Update each project references with preview 5. When I ran it (F5) I got:

Assembly: VersaComponents ( Attaching deployed file…

Assembly: GHIElectronics.TinyCLR.Devices.Can ( Attaching deployed file.

Assembly: VersaHelpers ( Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.Devices.Uart ( Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.Native ( Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.Devices.I2c ( Attaching deployed file.

Assembly: VersaStat ( Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.Devices.Display (

Error: the reference GHIElectronics.TinyCLR.Devices.Display cannot be used with this version of the firmware.

Firmware checksum 0x80BC83D7 does not match the assembly checksum 0x8CCBAEE3.


Link failure: some assembly references cannot be resolved!!

Assembly: TitanVersa ( needs assembly ‘VersaComponents’ (

Assembly: TitanVersa ( needs assembly ‘GHIElectronics.TinyCLR.Devices.Gpio’ (

Assembly: TitanVersa ( needs assembly ‘GHIElectronics.TinyCLR.Devices.Display’ (

Assembly: TitanVersa ( needs assembly ‘GHIElectronics.TinyCLR.Drivers.FocalTech.FT5xx6’ (

Assembly: TitanVersa ( needs assembly ‘VersaDataDefs’ (

Assembly: TitanVersa ( needs assembly ‘GHIElectronics.TinyCLR.Devices.I2c’ (

Assembly: TitanVersa ( needs assembly ‘GHIElectronics.TinyCLR.Devices.Pwm’ (

Assembly: TitanVersa ( needs assembly ‘VersaSerial’ (

Assembly: TitanVersa ( needs assembly ‘VersaCAN’ (

I check all bin\debug folders and all dll’s were there

What is wrong ???

Checksum mismatch

No you didn’t :slight_smile:

Did you use TiynCLR Config to update the firmware on your device? If so,start anew project and make sure the new “blinky” project works.

tinyconfig was the first thing I updated. i did use it to update firmware. When I tested with the simple project it worked fine.

That means your old project was not updated to use the latest NuGets

The simple project was updated to preview5 libraries and the 20260 was also updated to firmware preview 5. I did that as a first step to see if it would work. (that project was updated, it was not a new project). The problem is with the pre-produciton solution. It has 8 projects, an application and 7 DLL’s (to get around the 65K max assembly size)
This same thing happened when I updated to preview 4. I ultimately created a new solution and added projects/classes one by one by copying source code over.

I am curious if you had errors and you split your files or you just did split it anyway?

Also, what makes your code so large? Can you share your code with us under NDA? This coming release adds support for external flash and gives you a lot of flash. It would be great to test it with your code!

There is a packages folder in same your project folder, delete all of them and rebuild your project.

Is that the packages folder or packages.config or both ?

just folder