Main Site Documentation

Where is device capabilities in MF deploy?


#1

Hi Everyone,

I got my first FEZ board today after finally deciding to make the switch from Arduino to something a bit different! I admit that I didn’t check up on the firmware version to begin with as recommended (because I couldn’t find “device capabilities” ) and just went straight in and uploaded the example blink sketch, which worked fine. I then attempted the digital inputs tutorial (the second bit of code) and it got stuck on “Preparing to deploy assemblies to the device” and I think eventually an error came up.

Now I want to check I have the latest firmware installed, but I can’t find the “device capabilities” option anywhere. Under Target there is only three options, none of which are device capabilities.

The other issue is that now when I ping the device nothing is sent back. Should I attempt to update the firmware anyway? And if I should where do I find “FEZ Domino & mini.ghi”, I can’t see it any of the folders I downloaded?

Sorry for all the questions, this is completely different to what I’m used to!

Thanks


#2

C:\Program Files (x86)\Microsoft .NET Micro Framework\v4.1\Tools\mfdeploy.exe

Target -> Device Capabilities


#3

Welcome to the forum!

May be you have an old version or something?


#4

When the first program ran it should be fine, shouldn’t it?

I got this often when the last program is still running. When you stop Visual C# the PC stops collecting debug information but the Panda continues. Solution: press the reset button after starting the deploy. At least for me it works.


#5

@ SteH, are you replying to the wrong thread?


#6

Thanks Ianlee74, that worked perfectly! I did have to update the firmware, which I discovered could be done easily using the executable supplied :-[

Thanks again for the help everyone ;D


#7

@ ianlee
no. I have sometimes problems with deploying because the Panda is still running. A reset on the Panda solves this.

I was just wondering that the first program ran fine and the second didn’t. But when it is a firmware update that was missing - fine.


#8

@ SteH Hmmm… Thanks for the tips. All very good. I just couldn’t figure out how it related to finding the “Device Capabilities” in MFDeploy… :think:


#9

Sorry for so many questions! How do I set up the debugging window properly? I think I must have missed a step because at the moment the output window just prints:
"The debugging target runtime is loading the application assemblies and starting execution.
Ready."
And that is all it prints, I’m using this code:

using System;
using System.Threading;

using Microsoft.SPOT;
using Microsoft.SPOT.Hardware;

using GHIElectronics.NETMF.FEZ;

namespace FEZ_Panda_II_Application1
{
    public class Program
    {
        public static void Main()
        {
            OutputPort LED;
            InputPort Button;
            bool button_state;

            LED = new OutputPort((Cpu.Pin)FEZ_Pin.Digital.LED, true);

            Button = new InputPort((Cpu.Pin)FEZ_Pin.Digital.LDR, false, Port.ResistorMode.PullUp);

            while (true)
            {
                button_state = Button.Read();

                if (button_state == true)
                {
                    LED.Write(button_state);
                    Thread.Sleep(300);
                    LED.Write(!button_state);
                    Thread.Sleep(300);

                    Debug.Print("Button Press");
                    Thread.Sleep(100);
                   
                }

                else
                {
                    LED.Write(false);
                }
            }
        }
    }
}

How can I get the debug output window to print any useful values??

Thanks


#10

Does it print “Button Press” when you push the button?

You have to tell it what you want printed to the output using Debug.Print().


#11

@ ian - he’s got the debug statement in there.

@ Big Gorilla - I’ve seen a couple of cases where Visual Studio for some reason prints to the immediate window instead of the output window. It seems to be related to a default setting in the Express version, which can be changed back to the Output window. Disclaimer - this is SWAG (Serious Wild Ass Guess).


#12

@ ransomehall I see that. I have the feeling he’s expecting more to automatically appear. My point is that if he wants “the debug output window to print any useful values” then he has to explicitly tell it what to print.


#13

@ ianlee74
I wasn’t expecting any more than “button pressed”, I literally meant “The debugging target…” is all it prints! :wink: It seems that Debug.print() is very similar to Serial.println() in Arduino, so I was treating it in the same way, that is it prints either the value I tell it to or a value read from one of the input pins :slight_smile:

@ ransomhall
You were right! It was printing to the immediate window, I’ll see if I can change it back to the output window then :slight_smile:

Thanks!