Main Site Documentation

What's happening?


#1

Hello,

I’ve got a problem with my Domino, it’s not working anymore

The power led is blinking with “low intensity” when I power it from an external power supply but doesn’t light when powered by USB. It’s powered at 9V.

What I was doing was using a stepper driver (EasyDriver) and all was working fine. I was using a PWM pin to switch the “Step” input of the driver and left it run for about 1 hour (I had to leave the house during this time).
When I came back, the stepper was running by intervals and the power led was flashing. It was hot but not that much.

What do you think could have happened and, most importantly, how or if I can get it work again ?


#2

Is the Domino allright ???

[ulist]Power off.

Disconnect the additional circuit (wires, shields, etc,)

Visually inspect the Domino both sides to ensure that there are no shorts, discolored areas, strange smells or warm areas)

Use a simple LED flash program to test the board.[/ulist]


#3

I’m afraid it’s not :frowning:

With everything disconnected and only the USB cable, the power led doesn’t lit at all and no device is shown in Windows. I can’t send a program to it either. No board.

If I power it with an external regulated source at 9V, the power led is flashing with a low intensity and Windows sees an USB device that doesn’t work correctly.

Btw, by doing this test, I’ve just noticed that the NXP chip gets very hot in a short time (around 20-30 sec) :o
I didn’t notice any weird smell or discolored areas :snooty:

I think I should order a pickaxe and a shovel to dig some grave :’(


#4

One last indication : if I power the Domino with 5 or 7V, the power led doesn’t blink. But the NXP chip still gets very hot, and in less than 15sec I can’t put my finger on it ???

[italic]Edit:[/italic]
With a 7V external power, here’s what I get on those pins :

  • 3.3V = 2,1V
  • 5V = 3,2V
  • Vin = 5,02V

It doesn’t seem ok to me :think:


#5

Are you able to get a virtual serial port with Loader and Reset button?


#6

Not at all :frowning:


#7

I would suspect that your EasyDriver went south and took the Domino with it. That is the most common failure mode when driving a high voltage motor with non isolated control signals. Without any form of galvanic isolation anything going wrong in the motor driver has the potential to feed back high voltage through the control lines. A couple of cheap opto-isolators will save your butt, and control board.


#8

A couple of cheap opto-isolators [italic]would have saved[/italic] my butt, and control board ::slight_smile:

I was “playing” with both cards the afternoon during maybe 2 hours, with the motors running during roughly 30sec each time before I left it running a whole hour continuously. If what you say is right, 30 sec was short enough to not damage the board and I was lucky.

That’s weird, I think. I will try the EasyDriver board as it should not work anymore too, in this case.

Anyway, it seems that the result is this one : some control lines are fried, thus not allowing the Domino to work now.
In other words : it’s dead :’(


#9

Did you have the Easy Driver set up for 5V or 3.3V logic supply power? Even though the USBizi has 5V tolerant inputs I wonder how it tolerates an output being pulled up to 5V? Another possibility is that the board layout led to coupling between the stepper drive outputs and control signals (Out2A is right next to the S/D inputs). Lots of ways for a motor driver to cause problems with a controller.


#10

From what we’ve spoken about in chatroom, here are some measurement :

[quote]Power : 7V regulated = 7.32V

IC3 - Vin : 6.61V
IC3 - Vout : 4.95V

IC4 - Vin : 4.92V
IC4-Vout : 2.68V

On named pins :

  • Vin : 7.16V
  • 5V : 4.96V
  • 3.3V : 3.29V

NXP chip t° > 90°C, increasing 1° every 2sec
I’ve stopped the mesure at 90°, but it was still increasing… ???
[/quote]

[quote]Power : USB only

On named pins :

  • Vin : 1.61V
  • 5V : 3.12V
  • 3.3V : 2.16V

NXP chip t° ~= 60°C, increasing 1° every 10sec. Almost stable at 60°C
[/quote]

@ Jeff : I’ve shortened the small part in the lower left corner, so I was using 3.3V logic.

Edit: strangely enough, today the power led doesn’t flash anymore but is lit steady as usual, with “normal” intensity when powered from external source :o
Still not blinking but very low intensity when powered by USB, though (I was expecting this regarding the measurements).
In both cases, Windows does not see any USBIzi board connected :frowning:


#11

Have you measured how much current it draws?
With all the heat buildup I would assume that it is more than the expected 110mA.


#12

Doesn’t sound good… at least the vregs are generating the expected voltages.

Perhaps you burnt out one of the fets inside the mcu =\


#13

[quote]Have you measured how much current it draws?
With all the heat buildup I would assume that it is more than the expected 110mA.[/quote]

I believe so too. Have you tried connecting it to a powered usb hub?
Is it now running with a external supply?


#14

I have tried connections directly to PC USB, with two different USB powered hubs and with a powered USB cable. Same behaviour in all cases : power led lit with low intensity, no device in Windows, NXP chip is heating a lot.

I don’t know if “running” is a good term here ??? Anyway, I almost used an external power each time I was manipulating the board, as it avoids some weird behaviour with USB, for example :wink:


#15

Sounds like a fried voltage regulator(s).


#16

0.98A ! :o

Board alone, nothing except 7V power supply connected to it.


#17

That is not good :o that is not good at all :o

What have you done??? No wonder windows does not recognize it… :smiley: I hope you did not blow your usb port ???


#18

I’ve only let running for about one hour a program controling the EasyDriver board, which in turn drove a stepper at 1 step per second, via a PWM pin. Nothing more.

Before that, during nearly 2 hours (with some breaks, of course), I was testing different PWM parameters and different config of MSx pins of the Easydriver.

I didn’t notice any strange behaviour during this test period. But I have to admit that I didn’t check the temperature of the NXP chip either :hand:

The USB port is still working well, as I can use it to drive my Phidgets boards without any problem.

[italic]Edit:[/italic] here’s the program code. Nothing dangerous or wrong here, isn’t it ?

using System;
using System.Threading;

using Microsoft.SPOT;
using Microsoft.SPOT.Hardware;

using GHIElectronics.NETMF.FEZ;
using GHIElectronics.NETMF.Hardware;

namespace FEZ_Domino_Application2
{
    public class Program
    {
        public static void Main()
        {
            OutputPort led = new OutputPort((Cpu.Pin)FEZ_Pin.Digital.LED, true);

            OutputPort MS1 = new OutputPort((Cpu.Pin)FEZ_Pin.Digital.Di2, false);
            PWM pwm = new PWM((PWM.Pin)FEZ_Pin.PWM.Di8);

            pwm.Set(1000, 50);
            Thread.Sleep(5000);
            MS1.Write(true);
            pwm.Set(1, 50);
        }
    }
}


#19

No that seems fine… Maybe some expert knows a other situation where this happened?


#20

I don’t see anything wrong there.