Waiting for debug comands

Yet another newbie question. I have succesfully ran some programs with the Fez Spider
but something is happening now that has me confused. I downloaded the Altimeter Graphing Project.
Then in MS VS2010 went to properties\aplication and changed the target framework to net micro framwork4.2.
Hooked things up and hit F5. Looked Ok but the TE35 display after the usual EMX display just says
"Waiting for debug comands…" Not sure what this means. There are no errors or warnings showing up.
just hoping someone knows what is going on -Brad

Hi bds,

Welcome to the Community.

Sometimes this message will come on the screen you have attached because the program that you deployed to the board had some sort of exception and it bypassed the whole program and is awaiting any kind of program command. When you deploy the program, look at VS2010’s output window and see if there are any errors. This problem that you are describing is a classic firmware mismatch, but it can also happen if, as I said, an exception occurred somewhere in the program.

@ Aron,

My board does the same, after every reboot, without VS2010 connected. It stays there for 10 seconds, then loads my program. I guess it might go away if I redeploy my program, but I have not gotten arount to it.

Funny enough it is also a derived project from the altimeter graphing project. :slight_smile:

Aron, Thanks for the reply.
I had some other Issues before I could get back to my main problem wich is trying to get this project working.
So I am sure it would have helped if I had the output window open to see that yes, there was a problem!

output window:

Link failure: some assembly references cannot be resolved!!

Assembly: AltitudeGrapher ( needs assembly ‘GTM.Seeed.Barometer’ (

Assembly: GTM.Seeed.Barometer ( needs assembly ‘Gadgeteer’ (

Assembly: GTM.Seeed.Barometer ( needs assembly ‘mscorlib’ (4.1.2821.0)

Error: a3000000

The program ‘[3] Micro Framework application: Managed’ has exited with code 0 (0x0).
Waiting for debug commands…

At least I know what the problem is now. Just not sure what to do.
In the Solution Explorer The Gadgeteer reference has a version of 2.42

Maybee my question should be -what is a good book to learn C#.

@ bds - There are many good books on learning C#, however your problem at hand is that you need to update the firmware on your Spider. Fez Spider ships with firmware 4.1 until the 4.2 SDK gets out of the Beta stage.

Thanks for the reply. I am fairly sure I have updated the firmware.
When the spider boots the screen shows

EMX: Version

I updated at the end of the software intall.
I went to the MSV C# Help\About page and found under product details -

Microsoft .NET Micro Framework SDK v4.2

Is this my propblem?
Again being a major noob with programming, I am not sure what to do.

I think your project still tries to reference old dlls.

Go through all the references and make sure that all of them have the property “Specific Version”(or something like that) set to false.

All of the References are set to "specific version -false"
also noticed that the seeed barometer version is
wich is referenced in the line error line

   Assembly: AltitudeGrapher ( needs assembly 'GTM.Seeed.Barometer' (


Looks like a project is referencing an old assembler. Make sure the references for the AltitudeGrapher
are current. Remove them and then add back.

Do you mean delete all references in the solution explorer, and then add them back one by one?

@ bds - Yes

After a weekend of mild frustration I think that I may have at least found the actual problem.
All three of the Seeed modules I have on hand (Barometer,temp&humidity,and Compass) give the same error when I try to use them.

I used this basic program for the Seed Temp&Humidity module

using System;
using System.Collections;
using System.Threading;
using Microsoft.SPOT;
using Microsoft.SPOT.Presentation;
using Microsoft.SPOT.Presentation.Controls;
using Microsoft.SPOT.Presentation.Media;
using Microsoft.SPOT.Touch;

using Gadgeteer.Networking;
using GT = Gadgeteer;
using GTM = Gadgeteer.Modules;
using Gadgeteer.Modules.Seeed;

namespace GadgeteerApp1
public partial class Program
// This method is run when the mainboard is powered up or reset.
void ProgramStarted()
// Event that fires when a measurement is ready
temperatureHumidity.MeasurementComplete += new TemperatureHumidity.MeasurementCompleteEventHandler(temperatureHumidity_MeasurementComplete);

// Start continuous measurements.


void temperatureHumidity_MeasurementComplete(TemperatureHumidity sender, double temperature, double relativeHumidity)
Debug.Print("Temperature: " + temperature + " Relative Humidity: " + relativeHumidity);

Then I get the same output for all three Modules using similar programs.

Link failure: some assembly references cannot be resolved!!

Assembly: GTM.Seeed.TemperatureHumidity ( needs assembly ‘Gadgeteer’ (

Assembly: GTM.Seeed.TemperatureHumidity ( needs assembly ‘mscorlib’ (4.1.2821.0)

Assembly: GadgeteerApp1 ( needs assembly ‘GTM.Seeed.TemperatureHumidity’ (

Error: a3000000

The program ‘[3] Micro Framework application: Managed’ has exited with code 0 (0x0).
Waiting for debug commands…

References in solution explorer are as follows:

Gadgeteer  -version   (specific version set false)
mscorlib     -version     (specific version set false)

I can see that the numbers don’t match but again I am not sure what the heck could I do to fix this.
I have gone through the Getting Started with .NET Gadgeteer book using "GHI NETMF v4.2 and .NET Gadgeteer Package Oct. 26, 2012"
and every thing worked fine.
Thanks to all that have tried to help, and I hope I have at least finaly defined my problem properly now.

Hi Brad,

yes that helps explain things much better.

What you have here is the “classic” version mismatch issue, that comes up when the SDK’s get changed.

Your device has firmware 4.2 on it. Please prove that by using MFDeploy to report the “device capabilities”, as well as letting us know what the exact revision number is (4.2.5 is the most recent I believe).

Your SDK may or may not have 4.1 or 4.2; can you tell us exactly what SDK versions you have by looking in the release notes on your PC to confirm - for me I am running an old SDK, that states:

[quote]SDK Version 1.0.19
February 19, 2011[/quote]

[quote]• USBizi (FEZ Mini, FEZ Domino, FEZ Rhino, FEZ Panda) V
• EMX (FEZ Cobra) V, TinyBooter V
• ChipworkX V TinyBooter V
• GHI NETMF Library V[/quote]

My firmware needs to exactly match that number,, when I do device capabilities. Yours needs to match exactly the version your release notes says.

When you created a new project, did you select to create a 4.1 or a 4.2 project? There are other people with issues because of the Seeed drivers not being released as 4.2 drivers yet (GHI have said they are intending to take those drivers on the journey, but I don’t know for certain if they’re included in the 4.2 release candidate SDK currently available or not) and this may be part of your challenge.

Once we get all this unravelled and consistent across the board, you’ll be much better off, I am sure.

Thanks Brett,
Here is some more info.
Device capabilities:

HalSystemInfo.halVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
HalSystemInfo.oemCode: 255
HalSystemInfo.modelCode: 0
HalSystemInfo.skuCode: 65535
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
SolutionReleaseInfo.solutionVendorInfo: Copyright © GHI Electronics, LLC
SoftwareVersion.BuildDate: Oct 24 2012
SoftwareVersion.CompilerVersion: 410462
FloatingPoint: True
SourceLevelDebugging: True
ThreadCreateEx: True
LCD.Width: 320
LCD.Height: 240
LCD.BitsPerPixel: 16
AppDomains: True
ExceptionFilters: True
IncrementalDeployment: True
SoftReboot: True
Profiling: False
ProfilingAllocations: False
ProfilingCalls: False
IsUnknown: False

Sdk version info:

GHI Electronics, LLC
Premium SDK for NETMF v4.2

SDK Version 0.0.6
October 24, 2012

Version Info

Important Note: Requires .NET Micro Framework 4.2 QFE2 and Visual Studio 2010

EMX v4.2.5.0, TinyBooter v4.2.5.0
G120 v4.2.5.0, TinyBooter v4.2.5.0
GHI Premium NETMF Library v4.2.5.0

I created the projects using SDK 4.2 Project
When I open a new 4.1 project I only see Seeed modules (no ghi modules or main boards).
Thanks again for your help,


Then I think the only thing that you haven’t got working is 4.1, and that would require you to install the “optional” 4.1 GHI SDK from http://www.ghielectronics.com/support/dotnet-micro-framework (but Gus has said in the past 24 hours that 4.1 and Gadgeteer isn’t supported anymore - I’m not sure whether that means the portions necessary have been removed from the SDK)

But doing this will then also require you to install the 4.1 firmware onto your device.

I think the real thing that you want to do here is to use the Seeed devices on your board. Really, I suggest that the way to do this with minimum firmware version headaches in the future is to grab the source code for the drivers themselves and just add them to your project. GHI have said that they’re going to help move these drivers into the 4.2 world, but I don’t know when that might be complete.

Sorry, forgot to link in where to get the drivers.

http://gadgeteer.codeplex.com/ is the Gadgeteer project source repository.

http://gadgeteer.codeplex.com/SourceControl/changeset/view/23408#158030 is the Temperature Humidity device driver itself. You can navigate through the Seeed devices in the tree and get the others you need.

Thanks for the info. How would I go about adding the source code to the project.
Sorry about the basic nature of my question but I am new to programming.
I think I am coming from the wrong side with the gadgeteer concept.
I was looking to learn some programming. I have to say I have learned a lot in
the past weeks but still at the bottom of the programming learning curve.
It’s funny, I “program” for a living. But Programming CNC machines is a whole different thing.

Hi Brad,

sorry, you’ve hit a couple of issues here that are not your fault that have made this more challenging than you’d normally expect. You’ve just picked the wrong Gadgeteer modules to try to start with since there are only 4.1 drivers available. You’ve also hit the time between when the 4.1 SDK and the 4.2 SDK is being released, that means there’s a focus on addressing this change and little/no time is being spent on the drivers right now.

Out of interest, what devices do you have that you want to connect?

So here’s an example of how you’d do what you want (from memory, not practice). This is going to give you the driver, not the Gadgeteer designer portion that makes it simple to model this (although you could do it with some work - but I assume you really just want to use the device to get the temperature for instance.

Start a Gadgeteer project - add the other devices you want, and connect them as you would normally do.
Go to the code window. Add, New Item, Code File, name it the same as the driver on Codeplex (in this case, call it TemperatureHumidity.cs)
Copy the code from the Codeplex page. Paste into your new file.
In your Program.CS, reasonably early in ProgramStarted(), add a line like:

tempHumidity = new GTM.Seeed.TemperatureHumidity(5);

This creates the object for you to use, the only thing is you have to change is the "5"5 is the socket number that you want to connect it to. Here’s where you can cheat a bit because the 4.1 project will let you do this in the designer; before all this, in a 4.1 Gadgeteer project, figure out what socket you want to use and remember the number for this step in your 4.2 project. The Temp & Humidity device is pretty simple it’ll work on a Y socket but others you have might be a little more specific).

Then you’re done with the setup, now all you need to do is continue your app work.

hope this all helps. Keep asking questions, we’re all here to help

After a whole lot of trial and error I am getting through a simple program for the Seeed TemperatureHumidity module
and seeing data in the output window! I also have the Seeed Barometer and compass modules. I will work on getting output
on those using the same Idea from you last post. Then on to bigger and better things I hope.
Thanks so much for all the help.


cool news !

whatever you do don’t get disheartened, once you navigate past some of these curly bits you should progress quickly past that. And judging by your profile location, if that’s accurate, you’re only a dozen miles from GHI headquarters. Go up and visit Gus and get him to cut you some code !