VS2013 licencing


Need to make some updates to an old project running on an EMX FEZ Cobra 1.3 board with LCD.
Exisiting hardware and software all working fine but no development has been done on it in over 5 years,

When I came to fire up VS2013 Community Edition it moans about lack of valid license, refuses to connect online (“service not available”) and then the only option is to quit. Tried installing on another machine that’s not seen VS2013 before and it runs in 30 day eval mode but similarly refuses to go online to extend this.

I’m not posting here for VS2013 support but I am interested if anybody else here is having this issue as I suspect the remaining .netmf community is one of the last groups to be still using this VS version. I’m on 2022 for desktop projects.

If VS2013 cannot be resurrected (it maybe a temporary problem, I’m not sure at the moment) then are there any other options for this project? Can later VS versions be used?

I’ve only a few small changes to make to the code. Thought this was going to be a couple of hours work. Wasn’t expecting to hit the brick wall of being locked out of the development environment.


I do have VS2013 and VS2015 on same PC. Not sure VS2013 but I think it is still OK on mine. But I am sure 2015 is still working fine because I worked on it couple days ago.

Yes, some time it asked for license then I just put my email that I registered then it is OK.

if your project 4.3 then VS2015 is recommended anyway.

Great! I’ll move the project over to 2015 then (I’ve all VS versions installed).
2015 seems to be able to update its licence okay.
Didn’t know 2015 is the preferred devenv for 4.3 which the project is.

say the required version is 2013, FYI.
Not that the docs were why I tried 2013, that’s just the version the project was last seen in.

Anyway - I got VS2015 setup (the project setup needs to be installed from the online gallery rather than the .visix file) and all is good. Change made, built and deployed. Excellent!

1 Like