Main Site Documentation

VS2010 compiler/debugger problem


#1

Hi, I’m new to this hardware and .Net environment.

I am using VS2010 and Cobra 2 board. I did manage to deploy to the board and start exploring, but then things went wrong and hence I tried the very basic and still get an error:

I open a new project, .NET Micro Framework 4.2, select my board, Cobra II and run in debugger mode eg. Device = Microsoft emulator. I do get the following in my output window:

Loading Deployment Assemblies.

Resolving.

Resolve: unknown type: AnalogOutputChannel

Error: ff000000

I have uninstalled and reinstalled Gadgeteer/GHI libraries and tried to include all sorts of References and “uses” but no success. As I said, I was working at some stage, but I must have set something in VS which have changed something else.

Could someone please be so kind and assist? Thanks Ulf


#2

@ Ulfnam - Welcome to forum.

You should not be running in the emulator. The emulator does not support analog hardware.

In the Solution Explorer right click on your project and select Properties.

When the properties tab opens up, select the .NET Micro Framework sub-tab. In the Deployment area select USB as the transport, and then select your Cobra in the Device area.


#3

@ Ulfnam - If you are really new to this stuff, recommend the link to “starting your First Project” The link is found under our main Support pages “.Net Micro Framework” section http://www.ghielectronics.com/support/.net-micro-framework, Scroll down until you find “Frequently used Resources”.


#4

Thank you for your relies! I did all of this: I did select my Cobra 2 board, I selected Netmf 4.2, I did the “Hello World” program, I included DebugPrint messages and wre able to see them in my output window etc. etc, as I have mentioned, it was working! Until I ran into this problem. If I select the hardware board I do get the same problem and hence I have selected the emulator to eliminate that this could be related to hardware. So , NOT hardware, and my little " Hello Word" thing amongst other little test programs that used to work do not compile any longer… therefore I suspect that some setting in VS environment must have accidentli changed so that the assembler looks for this “AnalogOutputChannel” … I do not know where it is called from and why and this is where I am stuck.


#5

post the code for your simple program that has the analogoutputchannel error, also post screen shot of your references in the “Solution Explorer” then deploy to the actual Cobra II hardware and send screen shot of the output window.