Main Site Documentation

Visual Studio Toolbox not visible


#1

The gadgeteer SDK installer successfully integrated itself with a VS Express install.

VS Express was then uninstalled, and a full VS 12 Pro was installed.

The .NetMicro and Gadgeteer installers were run again.

The gadgeteer libraries are present, but in a New Project, no gadget toolbox items appear, and a new project produces a blank designer window.

How can this be corrected to restore the toolbox?

If the auto-code generator cannot run, is there a guide for manually creating all the auto code?


#2

I used this GadgeteerBuilderTemplates.msi


#3

Nice. Except it does not work on mine.

Tried reinstalling both those kits from the links you provided.

Blank toolbox.


#4

@ Jockey4her -

I ‘think’ I installed the Gadgeteer Core at the link also… I believe the Core is where the ‘real’ info is…

You need to have a device attached to see the template. At least when I first tried it…


#5

@ Jockey4her - it looks like you may not have the designer window open? – in “Solution Explorer” window, double click “Program.gadgeteer”


#6

oooo didnt know VS2012 could go dark ! just changed it. loveley jubbly…


#7

Blank.


#8

uninstall everything involved with the micro framework from GHI and MS, and then reinstall.


#9

That was it. Uninstall every single thing… then reinstall everything.

Thanks.