Main Site Documentation

Visual Studio Toolbox Empty


#1

I have installed/repaired the files outlined in https://www.ghielectronics.com/support/netmf, steps 1-3. My box is running Windows 8; I installed NETMF SDK 4.3 and for the life of me cannot figure out why nothing appears in my toolbox. When I create a Gadgeteer project, it prompts me for the mainboard, and I choose Fez Spider. It displays a host of other boards and at that point everything looks great. I click OK, and the project is successfully created, but no modules in toolbox. Any ideas? This is driving me insane.


#2

@ Mooo999 - Have you tried a complete uninstall and reinstall rather than a repair? What version of Visual Studio are you targeting, and is there more than one version on the machine?


#3

Hi Mooo999, welcome to the forum

The only other thing I would check is once you have a mainboard on the designer surface, go and check that the project properties are targeting the .Net framework 4.2 not 4.3. The current GHI SDK, while you need the Netmf 4.3 SDK to use with VS2012, is only 4.2 and all the modules will only appear if you have the project set to target 4.2.


#4

The mainboard never appears on the design surface is it is completely blank.


#5

ok, that is good to know.

Once the project is started, can you get to the project properties? If so can you take some screenshots and share them here?

I would also suggest that this is likely to be a “fundamental” problem with the VS install. I would uninstall the GHI SDK, the netmf SDK, and VS and reinstall from scratch.


#6

It is starting to look that way. So if I uninstall everything, is it better to reinstall vs 2010 or vs 2012? I will most likeley uninstall 2013 as well since I do my other dev work on an Azure VM so no need for that to hang around. I greatly appreciate the help!!!


#7

There’s no reason to go to Vs2010, 2012 works fine. Just make sure you always match the SDK version with the correct VS version and you should be fine… I personally have VS2012 Desktop installed along side VS2013 for Windows, Express versions, with no issue in either.


#8

As expected, no go. I uninstalled vs 2013, but left vs 2012. I uninstalled all of the GHI bits as well as the METMF 4.3. I then reinstalled all of the above. After I reinstalled, I simply went into VS and creaeted a Gadgeteer project using the Fez Spider. All of the boards show up, then it created the proeject and the attached doc is what I see. Nothing in tools and error messages at the bottom. Looks like I just need to try on a different machine.

Not sureif this matters but I do not have the board plugged in.


#9

I’d uninstall the GHI SDKs and everything they put down. Then uninstall the netmf SDK 4.3. Then uninstall the VS2012. Then install VS2012. Then netmf SDK 4.3. Then GHI 2013R3 SDK.


#10

Here’s one for u…the good news is my toolbox is filled with items, and the design experience seems to be working fine. I need to get the USB and the Fez Config to install, both have the same error as the attached image


#11

OK, just for the record, I was able to circumvent the “The advertised application will not be installed because it might be unsafe. Contact your administrator to change the installation user interface option of the package…” by opening a command window and running the msiexec /a “ghi fezconfig.msi”. did the same for the USB msi. Running the msi from the command prompt even if u r running in admin mode did not work.