Visual Studio Project Issue

I am trying to create a visual studio 2019 project and I keep getting this error…

I have tried professional and community editions with no luck.

Sounds like a corrupt file. Try these steps:,

  1. Do Project->Clean
  2. exit VS
  3. delete everything in the uProjects\TinyCLRApplication\packages directory.
  4. restart VS and try another build

If that still fails, then the nugetpkg in the global nuget cache may also be corrupt. You can open Tools->Options->Nuget Package Manager->General and click on the ‘Clear Nuget Caches’ button. If you manually downloaded the 2.1 files, then re-download them. And then repeat the above steps.

The idea is to keep working backwards to eliminate copies of that file and the nupkg that it came from because one of them seems to be corrupted and has a nul character in it.

Which project type are you creating? There are 4 options in v2.1

And welcome to the community.

So I am not sure what the root issue is… however if I dont pick a custom location for my project it is able to create it without the error just using the default visual studio location.

I tried picking the C#9 app and the C# app ones, I didnt try the library versions yet.

Ok, that’s kind of suspicious. Is the custom location on another drive? I always use the ‘custom location’ because I’m usually creating the app in a git repo somewhere outside the default user-profile-based location.

So in the image, I created a project and picked my H drive to create the project… it gives the pop-up shown. However if I leave it as my default shown in the created project it does not pop-up the error. I can work with this, we can close out this thread or however you want to handle it :slight_smile:

I don’t see why H drive doesn’t work. But, can we know what kind of this drive? I mean, is it a physical drive, thumb drive, network drive, read/write permission…?