Main Site Documentation

Visual Studio 2010 occasionally halts/aborts the "start debugging" process


#1

I’m not sure why, but every now and then (quite often actually), whenever I start debugging a project, Visual Studio (apparently) starts deploying the assemblies to the board but then soon after that it halts/aborts the process, with the following message then showing in the Output window:

“The debugger engine failed to receive any debug events from the debugging target”

I upgraded my Spider 1.0 firmware to version 4.2.11.0 just recently, along with the whole software stack on my dev box.: I have Visual Studio 2010 Ultimate and everything has now been upgraded to version 4.2. (NETMF, GHI libs, etc.). Whenever Visual Studio manages to successuflly deploy the project to the board, everything seems to just work OK.

This is bugging me and I can’t possibly imagine what might be the issue here. Googled the interweb extensively already, but to no avail. Maybe someone here might have a clue.


#2

Have you checked this ? https://www.ghielectronics.com/docs/109/usb-drivers-choices-including-winusb


#3

also, if you haven’t already, read sections on USB in https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#4

While both resources are indeed valuable, they are somewhat general in nature. I was hoping to find a more specific solution for this problem… something along the lines like “I had this same problem and I fixed it through this and that”. But in favor of the troubleshooting guides, I did experience a BSoD once (first time ever since I’ve started working with NETMF technologies), but I’ll hold off messing with USB drivers and such, hoping that someone will come up with a more pinpointed solution.


#5

Pinpointed in the sense that someone who has maybe experienced the exact same problem may have a more specific solution path to offer. I have read both guides pointed out here, but couldn’t find anything specifically mentioning my problem in particular. Apart from the BSoD situation, which happened only once with me, everything else seems to not apply to my situation:

  • my board is well juiced up (external power supply via a USB Client DP module)
  • I can always ping my device
  • there’s no “tight loop” running on my app that could prevent the debugger from attaching

#6

@ mpenna - I don’t have a solution, but from my experience developing with VS2010 on the Panda II, this only happens when my code has locked up or thrown an exception and therefore not exited cleanly. It is usually fixed by hitting the Reset button on the Panda II.

I had a lot more issues with VS 2010 before I updated to the WinUSB drivers, including BSOD when I reset the Panda II or disconnected the cable without releasing the device first.


#7

I’ll probably end up trying switching over to the WinUSB driver, but in my situation, what is most funny is that whenever this problem occurs, if I keep on trying, Visual Sutdio will eventually attach and indeed start debugging.


#8

Yesterday I finally tried the move to the WinUSB driver, making sure to carefully follow the corresponding guide (https://www.ghielectronics.com/docs/109/usb-drivers-choices-including-winusb), but right at the final step, when applying the new driver file, Windows blocked the attempt, saying that the “best” or “most recent” version of the driver (don’t remember the exact message) was already installed.

Maybe you guys know of another or alternative way of forcing the WinUSB driver.


#9

Uninstall previous driver and select to remove it completely. The it shouldn’t complain when you reinstall it.


#10

Yes, I did, otherwise I wouldn’t be able to browse to GHI’s WinUSB folder. I’ll try Architect’s tip and uninstall the current driver first. I’ll let you guys know how that goes.