Main Site Documentation

Visual Studio 2010 can't see G400 USB?


#1

So I upgraded my new work laptop and moved all my old development programs over to the new machine. GHI Firmware 2014 R1. Latest WinUSB drivers. FEZ Config can ping my G400 just fine. But no matter what I do, I can’t get VS2010 to recognize my G400 in the Project transport window (screenshot). It always says .

Any ideas what I should start looking at?


#2

Might be to obvious, but: Have you closed FEZConfig?


#3

Closing FEZConfig is not a requirement, but sometimes it does help.

Also, try another USB ports. For me, it even helps if I remove all the connected USB devices (any devices, not just G400’s) from the USB hub G400 is connected to.


#4

Yup, even with FEZ Config closed, the device still doesn’t pop up. Also tried different USB ports, and with no other USB devices connected.


#5

Reinstalling NETMF fixed the problem. I think installing NETMF 4.2 first followed by NETMF 4.1 may have goofed up the USB drivers somehow.


#6

It depends on what tab you have active. If its on a configuration page, or actively communicating to the device, you will have to close FEZ Config. Sometimes deployment works with FEZ Config open, but in my experience (Win 8.1) the debugger always fails to attach with it open.


#7

The problem has returned in a different form.

FEZ Config has not been used at all.

Now I can’t deploy. Please see attached screenshots.


#8

@ Iggmoe - If you could, can you please try to reset the mainboard within the first second after pressing deploy?


#9

@ James - Pressing the Reset button on the G400 within 1 second after deployment still fails.

I found a major clue (and workaround). I noticed that when I plug the G400 into a USB 3.0 port on my laptop, an entry for a ballpoint serial mouse sometimes appears inside Device Manager, in addition to the GHI NETMF Debug interface (screenshot). Deployment fails in this situation.

If I connect the G400 to a USB 2.0 port, deployment consistently works (fingers crossed).

And the really nutty thing: if I disconnect AC power from my laptop (which causes the CPU to throttle back and the PC to implement several power-saving features), I can deploy successfully via USB 3.0.

Something tells me some really nasty OS or USB handshake bug is lurking around somewhere.


#10

I’ll add to this that I spent a bit of time the other day trying to update a G400 and eventually I swapped the USB to a USB2 socket and it worked. I was trying unsuccessfully to do this on what I eventually discovered was a USB3 socket.

I can’t get consistent debugging of NETMF using USB3 sockets and have to switch them to USB2 and then there are no issues.

On that point, other devices and Android debugging works faultlessly without issues on USB3, even though they are only a USB2 device.