VideoOut Module Flicker Problem

Is anyone else experiencing this flicker problem with the VideoOut module? Any ideas on how to resolve it? I’ve tried multiple monitors and get the same result. Note the video is taken from a fixed mount. All movement aside from some auto-focus is coming from the module. I can’t imagine this could result from software. However, the software I’m running is located here:

@ ianlee74 - I do not have the module so I could not offer any real insight, but one thing I would check is if the flicker correlates with a GC. Maybe when a GC occurs the timing on the module is affected causing a flicker.

Shouldn’t be gc but that is easy to try

Actually, it’s harder than you would think… @ taylorza have you been able to run Pacman while connected to the debugger? It doesn’t work very well for me. Runs for a few seconds and then locks up until I disconnect the debugger and restart the Hydra. Is there an event I could subscribe to and write to the screen during a GC?

I’d thought about it being GC problem but I can’t understand how that could cause this type of problem unless something is wrong with the module or driver. GC has to happen sometime. Pause is acceptable during GC but screen shift isn’t. Not sure how well you can tell from the video, but I get momentary shift of the screen from 1/2" to ~4" sometime.

Hi Ian
Looks like vertical sync glitching. Check the VGA cable from the Video out module, you may have a break in VS line. Either that or its the module itself.
Gameplay doesnt look like it pauses and i would expect the whole screen to flicker if it was the board locking up.

I’ve tried two different cables w/ the same result. I didn’t mess with it anymore last night. What I want to do tonight is just do a very simple write to the screen that should not generate any GC and see if I get the same thing. If I do then I think I can conclude positively that there’s a problem with the module.

@ ianlee74 - I only ever run the code under the debugger. But I am still using the spider. I have a new game I started writting yesterday(Frogger) that is targeting the Hydra, and that has run under the debugger with no issues. I will check pacman under 4.2 and hydra tonight and see if I get the same result.

I ran it fine on Hydra w CP7 under Tinkr awhile ago. I could try and run it w the video out module why don’t you send me your code and I’ll have a go

@ Skewworks - @ ianlee74 has forked the code for the Hydra on codeplex

@ ianlee74 - OK, Pacman has been running under the debugger on the Hydra with the T35 display for about a half an hour now with no issues. Maybe @ Skewworks test with the VideoOut module will show something, unfortunately I do not have a VideoOut module to test that scenario.

I didn’t have any problems when I was running it on my CP7 with the Gadgetab but that’s been several SDK revisions ago… I’ll test it some more tonight.

I did a little more testing tonight and am still unable to run it in debug mode. I get a few seconds of video before it locks up completely. It works fine w/o the debugger attached. I’m hesitant to put the blame anywhere at this point just because I’ve been a little concerned about my computer’s health for a while now. I picked up a new SSD and hopefully will get time this weekend to do a complete re-install and upgrade to Win8 of my main computer this weekend. I’ll try again after that and see if anything is better.