Main Site Documentation

USBizi problem, cannot find device anymore


#1

I have a FEZ PANDA II and use it now allmost 4 months without any problems. I have installed the latest firmware and GHI USBizi drivers. But somehow after a few succesful deployments today I’am not able to deploy anymore.

I use VS2010 express and keep getting the error:

[quote]------ Deploy started: Project: testProject, Configuration: Debug Any CPU ------
An error has occurred: please check your hardware.
DebugPort.GetDeviceProcess() called with no argument
Source: Microsoft.SPOT.Debugger.CorDebug
Stack :
at Microsoft.SPOT.Debugger.DebugPort.GetDeviceProcess(String deviceName) in c:\depot\current\CLIENT_V4_1\Framework\CorDebug\DebugPort.cs:line 270
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.Deploy() in c:\depot\current\CLIENT_V4_1\Framework\CorDebug\VsProjectFlavorCfg.cs:line 809
at Microsoft.SPOT.Debugger.VsProjectFlavorCfg.<Microsoft.VisualStudio.Shell.Interop.IVsDeployableProjectCfg.StartDeploy>b__0() in c:\depot\current\CLIENT_V4_1\Framework\CorDebug\VsProjectFlavorCfg.cs:line 634
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========[/quote]

And if I look in the solution properties “.NET micro framework”, “USB” and than “Device” it is empty. I cannot select the USBizi device anymore. I tried reinstalleing the drivers but no succes.

Also no device appears in the device manager.

Please help, it looks like my device died :’(


#2

Hold LDR and reset, what do you see on device manager?


#3

Nothing happens, I use Windows7 and the red led of the Panada is on.


#4

plugged into a usb hub or straight to the pc’s usb port?


#5

Straight into my laptop.


#6

Pull out the usb cable from the laptop. Press and hold the LDR button. Plug in the usb cable into the laptop again, wait 5 secs and release the LDR button. Do you see it in Device Manager now?


#7

still nothing, tried it a few times like you described but nothing happens in the device manager.


#8

Is my panda dead? Can I try something more or reset the Panda to factory default settings?


#9

This morning I tried again with another USB cable, nothing and the led on the board it self also doesn’t work anymmore. After that I tried an external power source, same result.

Installing the drivers etc on a XP machine, same result.

Please advice.


#10

If you tried on another PC with still nothing, then sadly it is dead.


#11

Thanks you all for helping me out.

One last question, any idea how this is possible? I only worked with some temperature sensors and a GPS device.

Could I send my device back under warranty?


#12

Those boards are made to be very rugged but it is still electronics and static can cause damage to the board. You can send it to GHI if you like to check the it failed to due to a defect related to GHI and if it is under warranty. This is a $40 board so repairing these boards cost more than buying a new one.


#13

Hi all,
I have a same problem but my PC detects the device but there are two devices in device manager named as USBizi and CDC VCOM.
Also i did what you said with pushing LDR button and connect to PC but nothing changed.
This problem has begun when i tried http://code.tinyclr.com/project/191/telnet-type-class-for-netmf/ example. Could you help me about this issue. Is there anything to make the device factory default. I am using Panda II. Thanks a lot.
Regards.


#14

Start MFDeploy, select the USBizi and click on ERASE.


#15

with MFDeploy i cant see USBizi. so that i cant erase it.


#16

you are double posting. Limit yourself to one thread please !


#17

Hi All,
I am using:

  • Visual Studio 2010 Express Edition with SP1 (KB983509)
  • Microsoft .NET Micro Framework SDK v4.1 Version 4.1.2821.0
  • GHI NETMF v4.1 SDK

When I have deployed simple test program (USB Client with CDC - Virtual Serial) my board FEZ Panda II can not be recognized by my PC. Right now Device Manager shows only “Other Device - USBizi” and every time looking for driver for USBizi. As a result MFDeploy and USBiziUpdater can not communicate with board. At the same time Virtual Serial Port is creating and working correctly (board sends test message).

Holding “LDR” button, repair/uninstalling/installing “GHI NETMF USB Drivers 32-Bit” and “GHI NETMF v4.1 SDK” have not helped too.

If you have any ideas please let me know ASAP.


#18

Please start new post so it is visible

Welcome to the community


#19

I solve this problem by using the next steps (more details you can find in “USBizi User Manual”):

  1. Disconnect FEZ Panda II board;
  2. Press and hold “LDR” button at the same time connect board to USB;
  3. For verification look at Device Manager. You should find where new Virtual Com Port with description “GHI Boot Loader Interface”;
  4. Run TeraTerm Pro, select Serial (Com Port number from Device Manager) and click OK;
  5. Press couple times key “b” for communication (response) checking, as a result you can see reply “BL”;
  6. Next step is deleting the managed application code. Press Shift+D and when you will see “Erase deployment region?” press Shift+Y. Bootloader confirm it “Erasing…BL”. Or you can try also “Erase all flash memory (except the boot loader region)”. You should use Shift+E and Shift+Y to confirmation;
  7. Then Upload firmware… press Shift+X. After “Start File Transfer” you should go File-Transfer-XMODEM-Send… and select proper firmware in my case it placed on the path “C:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\USBizi\Firmware\USBizi_CLR.GHI” and also select “1K” (it is important point), then OK.
  8. After a few seconds “TeraTerm Pro” will finish uploading and into Device Manager you can see updated list of available devices. Where you can not find Virtual Com Port anymore but in “Debuggable .NET Micro Framework Device” section you will see “GHI .NET Micro Framework USB Debugging Interface”;
  9. After that you can again playing with your panda.