USB problem when upgrading TinyBooter from to

Hi, guys.

Were experiencing a problem trying to upgrade to NETMF 4.2. Were running on an EMX board, and upgrading TinyBooter works fine, however, after having installed TinyBooter version, the device fails to present itself as a USB unit.

Weve tried on Windows XP, Windows 8 and a Mac running Parallels Desktop, but on neither on these machines does it even show up in the list of devices. It is therefore difficult for us to try any of the mentioned tricks regarding manually pointing to driver installations[1] or hacking legacy drivers[2].

We have a number of these boards, and we have tried upgrading to on several of them; the effect is similar. It is also 100% reproducible that when we downgrade to, TinyBooter starts presenting itself as a valid USB device again.

Has anyone experienced anything similar? Are there any solutions to this problem? If this is a FAQ, please feel free to point me in the direction of where the question has been previously answered. Thanks! :slight_smile:


Lars T.


Please see the bold note in the same link you pointed out :slight_smile:

This will not work on Windows XP. Next release coming in few days take care of all these issues.

Hey, thanks for the quick reply, I appreciate it. :slight_smile:

Windows XP is only one of three host configurations we have tested it against.

We have tried Windows 8 and Mac with Parallels also. None of these platforms worked with either. Both of them work with

Is Windows 7 the only platform this currently works on? It would be good to know, because that would allow us to downgrade to Windows 7 and get going.

Thanks again. :slight_smile:

Windows 8 works fine but not virtual machines.

I guess our problem is of another nature then.

We have now tested on these platforms:

  • Windows XP
  • WIndows 7
  • Windows 8
  • Mac OS X

Common to all platforms is that TinyBooter works as expected while fails to even show up as a USB device. That means, does not show up with a “new device recognized” and does not give us an opportunity to even install drivers.

Is this something that might be covered in the upcoming fix, or is this another problem altogether?

We’re doing the installation procedure similarly for the different versions of TinyBooter: Pressing the %-sign over Tera Term to access the GHI booter, pressing “E” to erase firmware, transfering the TinyBooter using “X” and XModem, then pressing “R” to run TinyBooter. In all cases, on all the above platforms, registers as a USB device like you would expect any USB device to do while does not register in any way, except that the leds on the board show that power is being drawn from the USB cable.

Any help on this would be greatly appreciated, we have quite a few boards (70+) that need to be upgraded for a customer, and it is, as always, urgent. :slight_smile:

Is this a custom board? What is connected to the 3 “button” pins?

Hi, I have given you wrong information; I am sorry about that, I am relatively new on this project.

This is indeed a custom board. It is a board with an Embedded Master, it is NOT EMX as I wrote before.

Sorry for sending you on a wild goose chase, and thanks for the quick replies. :slight_smile: I assumed this was an EMX board as that is the identifier that we use to connect to it on USB, but that is not the case.

The boxes use no buttons or displays, the main usage is talking to vending machines using the MDB protocol.

Just to clarify, then, there will be no way forward to upgrading to 4.2 or future versions using this board?

Embedded master is no longer supported. You can’t use 4.2


I am the owner/product owner of this project,and therefor I must ask this question : How much longer will you be support Embedded Master, and for how much longer can we buy it.

We dropped embedded master about 2 years ago. Emx is the replacement. It is very compatible.

SO we can not get it any longer… The EMX does it match the Emb. master in the PIN-layout, I guess it is not…

Dan8, probably worth contacting GHI directly rather than the forum here. Commercial customers like yourself probably shouldn’t have conversations like this in public.

Yes it does match but contact us directly if you like.

Sure do you have an email adress, or ? Remember we are at least 7 hours ahead of you…


Please use contact us page and select sales.