Main Site Documentation

USB Not Recognized with G120 (Cobra II WiFi)


#1

I installed all the latest (.NET 4.3, GHI pieces 4.2), then plugged in the device via the USB cable. I plugged in my G120 and I was able to Ping it fine via the MFDeploy tool.

Then I accidentally clicked on the Erase button on the MF Deploy tool (which I am still not sure what it does) and ever since I get the USB Device Not Recognized error from windows. And of course, the the device is unusable since it doesn’t appear in either MF Deploy or Visual Studio.

I am not sure if clicking the Erase button had anything to do with the USB problems - could have been a coincidence, but here we are.

Here is what I’ve tried so far:
Rebooting Windows
Switching out the USB Cable.

Anyway, what can I do to fix the problem?

My setup is as follows:

Win7 x64 - installed on MacBookPro via BootCamp
Visual Studio 2012 - with all latest updates
Cobra II WiFi


#2

Use the LDR buttons to force in boot loader them update.


#3

Gus is referring to the LDR0 & LDR1 buttons on your Cobra mainboard. Unfortunately, I don’t see any specific documentation for that board regarding the firmware update process. So, my assumption would be that it is the same as what is shown in the chart on the G120 docs.

https://www.ghielectronics.com/docs/38/g120hdr-developer


#4

Ok, I held down the LDR0 and LDR1 buttons while booting and then released them. I fired up the MF Deploy, found the firmware for G120 and deployed it. It seemed to go ok. However, there was no confirmation that everything went ok.

Now, I fire up FEZ Config and plug in the device. It correctly, identifies itself as G120_G120. I click on the Ping button and it says: " Ping… No response from device." I then click on the “Device Version” button and a message box comes up stating “Failure - Device is not connected or not responding.”

The TinyBooter version is 4.2.7.0 - is this the correct version?

What am I missing here? How long should I hold the LDR buttons down?


#5

Ok, I figured it out. I had to go the entire route with replacing TinyLoader via TeraTerm, then update the firmware, etc…

It now works. It would be great if the MF Deploy devs added a Yes/No dialog for the Erase button.