Main Site Documentation

USB Host for unrecognized devices


#1

I have a 3D Connexion 3d mouse that I was to connect to .netmf. I’ve tried using the raw device but the device just isn’t showing up on my CerbBee. I was powering it externally but still no startup.

What could be the problem?

using GHI.Usb.Host;
using Microsoft.SPOT;
using Microsoft.SPOT.Hardware;
using System.Threading;

public class Program {

    public static void Main() {

        Controller.UnknownDeviceConnected += Controller_UnknownDeviceConnected;
        Controller.Start();
     }
    static void Controller_UnknownDeviceConnected(object sender, Controller.UnknownDeviceConnectedEventArgs e) {
        throw new System.NotImplementedException(); //<- never get's thrown
    }
}


#2

Check if any other events are firing.


#3
Controller.JoystickConnected += Controller_JoystickConnected;
        Controller.KeyboardConnected += Controller_KeyboardConnected;
        Controller.MassStorageConnected += Controller_MassStorageConnected;
        Controller.MouseConnected += Controller_MouseConnected;
        Controller.UsbSerialConnected += Controller_UsbSerialConnected;
        Controller.UnknownDeviceConnected += Controller_UnknownDeviceConnected;
        Controller.WebcamConnected += Controller_WebcamConnected;

None of the events are being raised with the 3D mouse. I can get the event to raise with Mass storage though.


#4

@ Mr. John Smith - Does the event get raised on an EMX, G120, or G400?


#5

Maybe your mouse has a USB negociation scheme that is not compliant with GHI devices. Can you give the PID and Device class shown by windows for your mouse?


#6

Hit reset button if use VS to debug. There is a bug the USB core does not reset completely if only reset CLR.


#7

Hi Dat Am I wrong or this bug is not reported?


#8

@ leforban -
you are right.
We just found when we tried to reproduce a different bug.


#9

@ John - I don’t have other .netmf devices to check so I don’t know if it works on the G120 and others.

@ Dat - Reset button?

@ andre - LoL bug love.

@ leforban - Class : HIDClass, PID : N4311340355


#10

Hum, I’ve tested 2 different mass storage devices and they both work. 2 different mice but only 1 works. Lastly I tried a usb serial dongle, and that didn’t work either.