Main Site Documentation

Usb DP board


#1

Hi,

i just got my spider the otherday and plugged it all in using USB and it worked fine, except modules like the camera etc were giving me issues.
So… i plugged in a 7v (after checking the web to see what voltages it could handle) plug pack into it.
instantly the screen gets lines on it and eventually goes all white, the spider drops connection to the pc (via usb) instantly.

unplugging either the usb cable or the 7v plug pack fixes this.

Is there something that im doing wrong? i have also now tried it with a powered USB hub, and i get the same problem.

the polarity is correct, and the 7v plug pack can power the spider without the usb connected.

it seems the screen does the same line to white thing if i hold down the reset button.

I was talking to someone on chat eariler, and it would appear im not the only one with this issue.

EDIT: i have tried 3 different plug packs - all centre positive


#2

So all work fine if you plug in USB including the camera? Using powered hub?


#3

Using USB (no hub).
Boots up, screen says

EMX
Version : 4.1.7.0
LCD 320x240
IP : 192.168.1.200
MAC 00.1a.fa.00.42.0d
Managed Heap size : 13041664
Custom Heap Size : 1048576

if i try to use the camera, i get
Camera ERROR : Unable to take picture. Camera is not ready. Is the Camera connected?
the screen never goes away from displaying the information above.

Plugged in USB Powered hub (no power pack)
Screen gets lines/goes white.
device makes no attempt to connect to pc, usb hub’s leds indicate there is no device plugged into the port.

Plugged in USB Powered hub + power pack
Same as with no power pack.

Plugged in with power pack (no usb connection)
Again displays

============================
EMX
Version : 4.1.7.0
LCD 320x240
IP : 192.168.1.200
MAC 00.1a.fa.00.42.0d
Managed Heap size : 13041664
Custom Heap Size : 1048576

But, if i try to plug any usb into there, the screen will fade to white and the device will stop working.


#4

ok, new info.

it doesnt complain if i plug the power pack in + use my usb powered hub without its powerpack.

So… really its a non powered usb hub.

BUT… i still cant get the camera to work, camera.takepicture always says it cant find the camera, and camera.ready is always false.

camera is plugged into slot 3 (where it told me to plug it in)


#5

Using a power hub without its power pack is very bad and defeats the point from having a powered hub.

Plug your camera directly to USB DP module, no mainboard, now plug to pc. Does windows recognize the camera?


#6

well if i use the hub with the powerback the spider compeltely shuts down and the screen goes white.

i have now tried this with a different usb powered hub (different brand to) and the same thing happends.

i will try the camera thing tonight.


#7

I initially had trouble with the camera image until I focused it.


#8

ok, pc identifies the camera if i plug it into the usb DP, (both with and without powerpack).

picks it up as a usb 2.0 camera.

Anything else i can try?


#9

So you know the camera is good. Now try us USB host socket with a USB memory or USB mouse. If it is detected you know mainboard is fine as well.

All should be good usually as these board go through many stages of testing and quality control.


#10

Hi

Got my FEZ Spider kit from Australian Robotics earlier this week and had a chance to try it out today.

I am seeing the same behaviour as was reported by Virus in the first two posts. The “Getting Started” app which uses the display, the camera and a button works fine for me with power coming from either the usb cable directly plugged into my new desktop PC or a power pack (in my case 9V 600mA). Trying it with both results in various combinations of lines on the screen, a screen that is all white or what looks like the mainboard resetting / rebooting.

Being a Newbie I am not sure what more I can do to get past this problem.


#11

@ LenF - don’t let your “newbie-ness” slow you down or cloud your creativity!

This “not so newb” has also seen this behavior, identical to what LenF described. I stopped using both power supplies at the same time early on, and will go back and try to reproduce it to provide specifics.


#12

So far, I am not able to repro here or I am not understanding the problem! What do I need to do to reproduce this on our end?


#13

[edit] So my memory does not serve me well. I was able to reproduce the flashing/white/reboot behavior only when the board was right on the edge of proper external power (6v) with no USB attached. I have one of those radio shack adjustable wall warts that puts out 1 amp at various selectable voltages. Anything above 6 (7.5 - 12) worked fine. Right at 6 (actually slightly less), it went freaky, but that could be considered expected behavior.

When I had both USB (from a powered hub) and external power, I could not reproduce the behavior regardless of what voltage I set the wall wart at.

Admittedly this was a ‘quick and dirty’ test, but it did serve clarify my own curiosity.

Moral of the story: check your power source(s).


#14

sweet, so im not the only one with this issue.

I too have a powerstation that lets me put out anywhere from 3-15 volts at 1 amp.

and at 7.5v (which is what im currently testing at) the device works fine provided the USB is not plugged in (so the power source can not be the issue), but the moment i plug the USB in as well, it goes white again.

i dont know if i can tell you how to repo it, as im sure what im doing is perfectly normal (using USB + EXT Power), and its simply not working right.

the only thing i can think of doing is sending you my board back, so you can see for yourself (but that would be a pain, as im in new zealand!).


#15

So lets summarize this, you have 7.5V on power input and the display shows some boot up messages, now you plug in the USB cable and the screen shuts down? Now what happens if you hit reset?

What I am thinking is that the ground difference between the power supply and the PC is the problem and when you plug the cable in this cause a little power glitch. The power supply has protection on it which kicks in to protect the circuit. This will be true if you hit reset and everything works as expected, even with both plugged in.

Can you guys confirm this?


#16

Results of some quick testing

“Getting Started” set up with:

  1. USB cable directly connected from USB DP board to desktop PC USB 2 port => everything is stable and reset button works as normal.

  2. Power from wall wart set at 9V @ 500mA and no USB connection => everything is stable and reset button works as normal.

  3. Simultaneous direct USB connection as described above to desktop PC and power from wall wart => various combinations of white outs and lines on screen - unstable and reset button has zero effect in resolving the problem.

  4. Connection to desktop PC via powered USB hub (got one today) => everything is stable and reset button works as normal.

  5. Connection to desktop PC via powered USB hub and with wall wart plugged in and also supplying power as described above => everything is stable and reset button works as normal. Would there ever be a reason to use this combination in practice?

In summary the “dual connection” issue occurs for me with a direct USB connection to the PC and reset doesn’t resolve the issue.


#17

Interesting! Do you own a volt meter? If so, take a look at this http://www.ghielectronics.com/images/catalog/280-2_large.jpg and give me these measurements please

Connect the board so it is in “not working state” then please give me the voltages across these capacitors
C1:
C2:
C3:


#18

@ Gus - I only get the odd white screen/reboot behavior when the board is under powered using the barrel jack. I did not see the behavior when adding USB power when the external power already there, regardless of voltage. In my case, the USB hub and wall wart shared a common ground.


#19

What is “under powered”? You mean it is less than 7V? If so, then this is normal.


#20

@ Gus Re “Do you own a volt meter?” - short answer is no but I will see if I can prevail upon a friend or colleague to lend me one. Maybe Virus, who has a similar issue and lives in a similar time zone has one ??