Main Site Documentation

Usb device not supported


#1

Hi guys,

I get this in my output window

UsbHost ERROR : USB device is not supported by the Gadgeteer driver. More devices are supported by the GHI USB Host driver. Remove the USB Host from the designer, and proceed without using Gadgeteer code

Does this mean i cannot use my usb device with gadgateer. When i use the same device with chipworkX it works just fine. I’m using it on FEZ Spider now.

Help please


#2

It just telling to try GHI non Gadgeteer driver and don’t use designer. And since it work with CX you should be able to work with it on spider using GHI libs directly.


#3

@ andre.m i’m using a swipe card reader.

@ Architect how can is use GHI library directly if gadgeteer is 4.2 and Ghi is 4.1


#4

@ Donnovan - There are GHI Premium libraries for 4.1 and for 4.2

This is the one you need:

http://www.ghielectronics.com/downloads/NETMF/Library%20Documentation%20v4.2/Premium/Index.html


#5

Thanx Architect,

But this doesn’t seem to to work. I tried the designer code again here is where I detected a problem, when i pull the device out of the host en connect it again it does work, Still using the designer code.

Any idea?


#6

Same idea as before. Try using non-Gadgeteer approach.


#7

Gadgeteer drivers only expose some, not all USB Host features.


#8

@ Architect : Yes I did and it works.
But does anyone know why the usb device isn’t detected the first time.
When it does get detected, i can use it one time and then i have to unplug it again for it to work.


#9

As Gus said, some of the features are just not there in the Gadgeteer driver. So may be that is the reason why this device is not working as expected. A certain event is not handled properly for example which will make a “working” device stop working after awhile.


#10

I am working on something which I will be releasing shortly. It uses a USB Host interface. I tried to get it working in a Gadgeteer environment, without using the designer, but there seemed to be a problem with the connect insertion event even though I was using the Premium library API. When I went to a console program, the event(s) worked correctly.

I was too lazy to get into the Gadgeteer source to see if I could find out why there was a problem.


#11

@ Mike is the interface finished :slight_smile:


#12

http://www.tinyclr.com/codeshare/entry/681