Main Site Documentation

USB Connection Problem with CANxtra


#1

Hello,

I have problems with the connection of CANxtra to the PC via USB. Running Win7 64 Bit with the latest USB driver from GHI webpage. Embedded Master Dev Board and Embedded Master on BreakOut Board still running fine on the system. No connection Problems.

If I connect the CANxtra Board, the Computer tells me that that the Device is unknown.

So I tried to Update the Firmware on one CANxtra Device. Updating the TinyBooter via COM Port was no problem. But deploying Firmware files din’t work cause of no connection via USB. Network Connection works also fine. MFDeploy can find the device.

So, anyone an Idea what to do?


#2

Did you tried other USB ports on the pc?


#3

Is this a new CANxtra? Have you used it before? If not, how about stepping thru the firmware update process to make sure its got all the right firmware on it?
http://wiki.tinyclr.com/index.php?title=Firmware_Update_CANxtra


#4

Brett, he did that. The problem is after the initial update through serial. He has problems installing the driver in order to be able to do the update with MFDeploy.


#5

Thats the point.

The Boards are new. Originally Firmware is 4.1.3.0. Tried to update the Firmware on one Device (have bought two). The first step was no problem. Updating the Tiny booter via TeraTerm and serial connection already wored fine.

But that didn’t solve the problem of the unrecognised USB device and so I couldn’t deploy the firmware files with MFDeploy.


#6

Is it connected to the PC directly or through a hub? Have you tried another PC just in case?


#7

Connected directly to the PC and tried other PCs with other OS (WIN7 32 and WinXP). The embedded Master Dev Board and BreakoutBoards worked fine on all PCs, only the CANxtra shows The unrecognised Device Message. If I trie to update the driver manualy and point to the GHI Directory it tells me the the best driver is already installed


#8

And you have 2 CANxtra you said? Both have the same behavior?!


#9

yes