Main Site Documentation

USB CLient SP not recognized in W10


#1

Hi everybody,

I’ve just bought a new FEZ Hydra Board to deploy an old project !

I’ve bought it with an USB Client SP and it seems that is not recognized by W10 in system manager !

Anybody knows how to have the right driver dor that ?

I’ve followed all those steps
http://www.ghielectronics.com/support/netmf

But that’s not working…

Thanks


#2

Simplest question first. Do you see anything in Device Manager, and does it make the device connected sound?


#3

Hi Brett, thank you for reponding !

So first (my fault), this is an USB Serial SP1.1 !
In device manager I can see an USB to Serial Adapter now, but I can’t communicate with the board !
I’ve got an USB Client SP1.3 too but I’m experiencing problems to comunicate with that one too…


#4

They are two different connections. They may connect power, but they don’t both allow connection to the PC for deploying apps. You must use the Client SP. What do you see when you connect that to the D socket? And have you tried swapping cables - the USB cable, and the Gadgeteer cable?


#5

I’ve just tried to change both USB and gadgeteer cable and its always the same !
When powering up I can see FEZHydra build date… on my display TE35 and then screen is going white.
And while deploying, in the output, “Looking for a device on transport ‘USB’”, “Starting device deployement…”, “Iteration 0” and then “Error deploying” !


#6

In FEZConfig when I plug the USB, I can see the board but when I trie to ping, there’s directly a device not connected status…


#7

ok so you’ve progressed past where we were talking about Serial SP and USB Client SP - lets not confuse the situation.

Device Manager must correctly show a device, with a functioning driver. That’s all I asked initially, and I’m assuming that it’s working now based on the above.

Next step, get firmware confirmation that the device is functioning and has the same as your SDK - use Fez Config to check. However it sounds to me that there’s an app deployed to the board - you should boot into the bootloader and erase. I’d also not have a display connected (it’s one of the more power hungry components and could be causing part if this behaviour). Might be worth looking at http://ghielectronics.com/docs/165/netmf-troubleshooting to see if that points you to info that’s useful.


#8

Ok sorry…
So with the USB Client SP, I see FEZHydra in device manager !
With the link you provided, I’ve tried to erase any deployement in this new board (display disconnected) but any action I do respond with NoConnection in MFDeploy and Status;No device in FEZConfig…
They are talking about a manual booter in the document… Do I have to do that and how ?


#9

Check Device Manager and see what device it shows.

https://www.ghielectronics.com/docs/39/fez-hydra-developers-guide also has a section on the loader update process (that you should use to redo the loader, as that erases everything). Then, you can make sure you can purge an existing app, deploy a new “blinky” app, and then start getting back to your real task at hand…

One more tip, the first link I sent talks about a tight loop - that’s prossibly why your app doesn’t respond to subsequent deployments. You can get around that by adding wait states early in the app’s startup such that it waits for a IO input or something until starting the intensive work. That will help you in development, and you can get rid of it or shorten the wait for real use.


#10

So I’ve followed The Hydra developers guide, grounding pin 8 on port 3, a Bossa Program Port (COM8) appears in device manager, I ran UpdateLoader then (administrator mode) with 8 as the port number but it returns “Connection com8 not found”…


#11

MFDeploy says “NoConnection” on COM8 too, while it sees the COM port as an existing one !


#12

Bossa port is good. Can you change to a lower COM port number (in case that’s the fault) and reset the Hydra, and try again?

Failing that I would need to step thru that with my Hydra - 24 hour before next valuable response :slight_smile:


#13

Thanks a lot, really, for helping me…
So I’ve change the COM Port number to 1, then reboot grounding the pin, COM Port reappears as COM Port 1, and UpdateLoader returns the same thing but with “Connection com1 not found” of course !
Waiting for you tomorrow to go forward…
Thanks again,
Regards,
Ludovic


#14

PS : I’m in France so its 1AM for me now, so never mind, maybe I’ll not see your response directly if you come back at that hour :sweat_smile:


#15

it’s 9:30am in Sydney AU where I am, and I do most of my work here early morning :slight_smile: So it may well mean you have a reply late in your day (if I get a chance to look tonight) or late late late your day so basically early morning :smile:


#16

It’s 9:30am Sydney on Saturday, and therefore 1:30am in France.
I can’t repro what you see. I have connected the Hydra in loader mode, with Bossa Port on COM6. I then went and re-ran the firmware loader app (C:\Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Firmwares\FEZ Hydra and “update loader.bat”. That worked fine (it took a while). After resetting the board, it shows up as a USB device, “FEZ Hydra”. When I PING it in Fez Config, I get “Tinybooter” response. I then do a Firmware Update, it knows it is in tinybooter mode, it then loads the firmware, reboots, everything looks fine.


#17

Hi Brett ! Can it be a ClientSP issue for you ? As it’s the same bug with 2 boards with a new one in the 2…


#18

could be, but I’d suspect the cables first :slight_smile: Have you swapped the heck out of them? Do you have a USB Client DP or another SP around? You could perhaps use your USB Serial module and put your board in serial debug mode to get it to work that way?


#19

I swapped both usb and gadgeteer cables already ! How do I put the board in serial debug mode ?


#20

I’ve ordered a new USB Client SP !