Main Site Documentation

USB and FEZ cobra not reconizing by my PC


#1

Hello,
I beginner and I’m building a robot with my FEZ Cobra. My problem is, when I use the external 5V to power the FEZ cobra, my PC (HP8540+windows XP) do not see the FEZ Cobra.
If I want use the debug with VS2010(or MFdeploy), I must remove the external +5V and plug the USB cable, the first power is done by the USB port. I can reconnect the external +5V and continue to work normally only after this manipulation.
What is my fault ?


#2

Where did you connect 5V?
A picture of your setup?


#3

Well, I have soldered a connector in the holes on the border of the card. I use the pin +5V in/out pin.


#4

If you have 5V stable power source on that pin then everything should function normally


#5

You need to check the voltage and current on your external power supply…

There is a protection diode on the USB port to stop higher voltages getting to the PC… but not visa-versa. If your external supply is weak you may be pulling too much from the PC when plugged into both supplies.

I have the same setup but my switched mode unit supplies at least 3A so there is no problem when plugged into the USB for deploy…

Cheers Ian


#6

Hello,

My work was :
The +5V is regulated correctly. All fonctions of the robot are correct.
I have soldered a resistor (1K for about 5mA) before the protection diode on the Vbus and GND. It’s the same thing.
I must disconnect the +5V before for the PC recognizing the FEZ cobra and after I can deploy my program. Why ? Bug ? A fault of my part ?


#7

So in reflection… When connected to an external (suitable) 5v supply, and functioning correctly… Once the USB is connected the PC does not recognize the FEZ… Or If the USB is connected first and operational, then the external 5V is connected, its ok…

If this be the case the only thing I can think of is your program is dominating the FEZ processor and can’t initialise the USB connection…
Its as if the housekeeping is miles behind.

I have tried my setup and it works either way round…

Cheers Ian


#8

Yes, it’s exactly what’s happen.
So, how can I do for my program do not dominating the FEZ processor ? Perhaps, I have missing a instruction or manipulation ?


#9

All I know is… I had an image rotation routine that rotated an image 10 times… It worked well on the emulator, but on the cobra it locked up the system. I looked to all and sundry that all was well, but the housekeeping got further and further behind… I didn’t catch on at first, but user response eventually went completely… You’re not using the SD slot by any chance?

Cheers Ian


#10

Actually I don’t use the SD card, but for the futur, i think use it. but why ?
Perhaps I must wait a long time with the USB connected for see if the PC see the cobra ?


#11

Just to test… Why don’t you try a small sample program… led blinking or something and try USB and external supply in different combinations.

See if it works.

Cheers Ian


#12

Ok I will try. I’ll communicate the results.


#13

Just for the test.
I have tried a simple programm (LED blinking)
USB power supply, the PC detect no problem.
External power (+5V external regulated), same problem. No USB detected.
I have tried with an antoher PC it’s the same thing.

My observations are :

If I powered my the FEZ Cobra with the external +5V and I put the USB connector the PC don’t see the cobra.
I remove the external power (the USB is always connected) no connections from the USB is seen.
I remove the USB (the FEZ is no powered) and I reconnect the USB, the PC see imediatly the FEZ cobra via the USB connector…

What’s happen ?


#14

Ok. My cobra runs a large program (based on the GHI demo) when I power it up via my 5v switch mode supply (connected to Gnd and 5V on the edge connector) the program initialises and runs ok… When I plug the USB cable into the PC, the PC recognised the Cobra immediately!!! So I do not have the same problem…

If I unplug the wall socket… Then insert the USB cable… It powers up as normal aswell…

We need to ask GHI if its because the GHI demo has the USB up and running… may be you have to initialise the USB on the FEZ in your program?

I think you need their help on this.

Cheers Ian


#15

Measure your 5v power and tell us what it is exactly


#16

Ok I have found the problem.
I try to explain .

On my robot I have connected the I/Os on the header for somes sensors. One of this I/O is the I/O IO71 or LMODE. On the EMX user manual it’s explain on the page 18 this I/O must be tied to low for a normal operation. Unfortunatly, this pin has a pull up to 3.3V in my robot. So the FEZ cobra begin in Emergency GHI boot, and it’s use the COM1 and not the USB port !
Thank you for your help, for have try to solve my problem.
Next time, a I’ll read all documentation before send a SOS on the forum.
Regards
Didier


#17

Not at all… Anything found even by accident is valuable on this forum… I’m just glad you’re up and running…

Cheers Ian