Main Site Documentation

Upgrading to NETMF and Gadgeteer Package 2014 R1


#1

Sorry if this is a really obvious question, but I haven’t used the gadgeteer for a while! I’m having a problem knowing what to expect when trying to upgrade to the latest 2014 R1 package for Gadgeteer.

I have a FEZ Spider Mainboard, and had installed 2013 R3 on my main PC a while ago.

I then installed 2014 R1 onto a laptop, and FezConfig indicated that the TinyCLR firmware version was out of date (version on PC: v4.2.11.2, version on mainboard: v4.2.11.1).

That’s fine - but before I put the firmware, I went to check on my main PC. At this stage I wasn’t sure if 2014 R1 was on it, or 2013 R3. Anyway, on the main PC, FezConfig said everything was up to date (version on PC: v4.2.11.2, version on mainboard: v4.2.11.1), indicating this has 2013 R3.

So, I tried to install 2014 R1 on the main PC, to ensure everything is up to date and so that it works on both this and the laptop.

When I tried to install it, over the top of 2013 R3, every package installer simply asks ‘Repair or Remove’. I had assumed it would just update the packages. Not being sure what you’re supposed to do, I chose ‘Repair’ for all packages. But FezConfig still indicates firmware is up to date, so it looks like 2014 R1 didn’t get installed.

Are you supposed to actually say ‘Remove’, and does the installer then put the updated package on? Or do you have to uninstall all packages somehow, and then start totally from scratch?

I’ve tried to search the forums and website for a possible answer, but I can’t find any description of what exactly the procedure is to upgrade. Normally I’d expect it just to update the existing version automatically, rather than ask ‘Repair/Remove’. However, if it’s normal that you need to uninstall, or that you need to say Remove and have it then uninstall then install the updated package, it would be good if this was stated somewhere obvious. Perhaps I’ve overlooked it?

In case this is not actually normal behaviour, and is a problem, my system is Windows 8.1 64 bit, and I’m using VS2012.

Hope someone can help!

cheers,


#2

Usually when it asks if you want to repair or remove it means you have the same version you are trying to install already installed on your machine. The quickest solution is to just remove all GHI products in the Programs and Features part of the Control Panel and then install the new 2014 R1 SDK.

In the 2014 R1 SDK folder that you downloaded, can you open the GHI Premium NETMF v4.2 Release Notes.rtf file and tell me what version and date are at the top? Assuming you installed the SDK you have currently to the default location, can you navigate to C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK and open the same GHI Premium NETMF v4.2 Release Notes.rtf file and tell me the version and date in there?


#3

So normally when upgrading, you’d just see each package upgrading - i.e. as you’d expect?

It was 3 in the morning when I was doing this! - so there’s every chance I ended up downloading the 2014 R1, but then mistakenly installed 2013 R3 again.

When I’m back home I’ll check those docs for their version numbers, and then have another go… and at a more sane hour of the day, hopefully :slight_smile:

Thanks


#4

That is correct. when upgrading, you will see each package upgrade as expected.


#5

Well, I can confirm… that I am an idiot!

I mislabelled the folder. From now on I’m not installing anything after 2:55am at the latest. :slight_smile:

Thanks for the help, and apologies for doubting the GHI installers!