Main Site Documentation

Upgrading Firmware - Stuck on Erase


#1

Hi,

I’m upgrading the firmware (for FEZ Cobra), but it seems to be stuck while erasing. It is still sitting at that spot (10 mins later). What should I do? (its still connected and at the same point)

Extract from teminal:

1.02
BL
BL
Erase all memory! Are you sure?
Erasing…


What should I do? Please help!

Ross.


#2

Hi Ross,

my FEZ Cobra returns

1.01
BL

and yours

1.02
BL

So I didn’t know the difference ???

Have you seen the video for updating the FEZ Cobra?

http://www.youtube.com/watch?v=Y4Va_tPqqpg

I have updated my FEZ Cobra several times wihout any problems

Did you use the USB port only for powering or an external power supply?


#3

Make sure you have enough power. Keep waiting as long as you see stars coming back


#4

I have followed the video. it just seems to have gotten stuck. I have done it several times with EMX development board, this was the first time I tried with FEZ Cobra.

Its been sitting on this for nearly 2 hours, so dont think its doing too much, or is going to…

What will happen if i unplug it and start again? Risk of bricking it?


#5

I took the punt and resetted it. Worked out second time around. I hate flashing chips, always worried about killing them!


#6

Not FEZ :slight_smile: You can NOT kill FEZ while re-flashing it, we have made sure of that :wink:


#7

Ross,
I didn watch the video cuz I dont have cobra, so I am not sure if this apply for cobra or just older boards, check to make sure on the transfer screen you select “1K”

-Hai