Main Site Documentation

Upgrading fez cobra 1.3 to tinyclros


#1

Hi, I’m trying to get back into this stuff and after having completely failed to find a place to buy a new fez I’ve dug out my ancient cobra but I’m having real trouble getting my older cobra updated to use all the new things.

There doesn’t seem to be a legacy page specifically for this board but I think this is an EMX based cobra.

Plugging in via usb produces a device who’s drivers I can’t find, tried to install the netmf 2016 sdk but it fails. I got it into usb serial boot mode but the device cannot start (Code 10), the forums seem to suggest all sorts to fix this but I’ve not been able to get any of it to work. I’ve tried the non-default drivers (as linked on here) but they don’t work either and any disconnects cause my machine to hard crash. I’ve tried using com1 and the lmode pin down with a ftdi board but nothing is ever returned over com1.

All this is me trying to update to the new bootloader. Which I /think/ I need to do?

Anyway, would be great if anyone has any suggestions as to what I need to do to get this thing updated and running again with tinyclr.

I’m running on windows 10, tried usb 2 and 3 ports, various hubs. Any help would be greatly appreciated.

Thank you!


#2

Here it is http://docs.ghielectronics.com/hardware/breakout/fez-cobra.html
Which leads you to the emx page.

On the emx page, read the note about error code 10 please.

You are on the right track.


#3

Thanks for responding to me.

I saw that note. All my machines are windows 10. I don’t have access to anything older.

I have also tried the direct serial interface but I get no response from the device. Any further suggestions are very welcome.


#4

To use serial, you need a serial port and you need to wire it to your board.

Another option is to upgrade. I think EMX is almost 10 years old. The new FEZ will be in stock in the coming few weeks or use something like FEZ Cobra II.


#5

Thanks for responding to me.

I’ve already tried using the com1 serial option. I have now tried again. I can get no response from of com1. Can you please tell me the settings I should be using to talk to com1? I have tried to use both a ttl ftdi and usb serial port. Both of which work with windows 10. I’ve wired the ttl ftdi into a loop to ensure the terminal was functioning and it was.

The instructions are also a little unclear as to how I’m supposed to get the bootloader to use com1. LMODE seems to do nothing. Can you please give me specific instructions for the EMX?

I will absolutely pick up a new fez when they become available but I have this 7inch tft that goes with the cobra and I’d love to get some use out of it.


#6

you did click the link that went to the EMX page, didn’t you?
http://docs.ghielectronics.com/hardware/scm/emx.html


#7

I clicked the link and loaded the whole web page. It does not say anything about using com1 instead of the usb serial port. Another page says that I should be pulling LMODE low, which I have tried. But not what other combination of pins are required for getting it to work. LMODE alone does nothing, but then with 3/7/53 it seems to do nothing either.

What serial config do I need to use to talk to com1?
What pins must be held low to get the com1 port working?
Is ttl acceptable for talking to com1 in this mode?

Thanks in advance for your help with these questions.


#8

How did to connect the serial port? Please take a picture of your board and wires to share with us.


#9

I’ve tried a whole bunch of thing at this point. Here’s one of them. Sorry it’s not very exciting.


#10

Looks correct. Did you set the terminal correctly?

You need to set the board in loader mode manually. I think you hold all three buttons down while resting the board. You also want to set mode pin in uart mode.


#11

I was just about to solder a jumper to LMODE to pull it low to be absolutely sure it was set correctly and I went to double check and found this:

https://docs.ghielectronics.com/software/tinyclr/loaders/upgrading-v1-to-v2.html
“Set the down and select pins low on Embedded Master or the LMODE pin low on EMX.”

http://files.ghielectronics.com/downloads/Documents/Manuals/EMX%20User%20Manual.pdf
“General purpose digital I/O is used to choose the access interface for EMX between USB
(Low) or COM1(High or not connected) on startup (refer to EMX access interface section)”

So this might be my problem. I’ve been following the instructions on the first page which says to pull LMODE low for com1 - whereas the manual says to pull it high.

I will test pulling it high.


#12

That did it. I’m updated now. Pull LMODE high and press and hold IO0 IO30 and IO4 during reset.

It would be worth updating this page to remove the error. As that’s what got me stuck for the longest:

https://docs.ghielectronics.com/software/tinyclr/loaders/upgrading-v1-to-v2.html

And the only place where the baud rate is specified for this mode is in the following document where it it wrongly written as 152000 (should be 115200).

http://files.ghielectronics.com/downloads/Documents/Manuals/EMX%20User%20Manual.pdf

Thanks for the help.


#13

While the docs needs some improvements, we are glad to say that our 10 year old products still work today, and using TinyCLR :grin:


#14

It’s very impressive. :slight_smile: I’m toggling leds now.


#15

Is GHIElectronics.TinyCLR.Drawing not supported on EMX? I’m having screen problems.

If not, do any of the new fez devices support this 7inc lcd (TFT7PN-DL-206)?


#16

Drawing is unfortunately not supported on the EMX. This doc lays out what is supported on what device.