Main Site Documentation

Updating Tinybooter USB Issue on Spider


#1

Arrgh, I am having a hard time here with my USB mess.

Updating the firmware goes fine. But Tinybooter update with FEZ Config does not see the Spider.

Although it is visible as COM9 in “Devices & Printers” as GHI Bootloader interface.

Looking into the Device properties it says “This device cannot start (code 10)”.

Whats preventing it from starting?
EDIT: Looked at https://www.ghielectronics.com/community/forum/topic?id=10960&page=1

But dont have USB 2.0 in the house…


#2

Have you got an usb hub ?

I have same problem without one.

I hope it is only that.


#3

Would it make sense to say that many USB hubs probably converts down to USB 2 when needed?


#4

You would say you only have 3.0 ? No external hub with power ?


#5

@ njbuch -
Hi,
I just have the same issue, did you solve it in the meantime?
Cheers
Roland


#6

@ njbuch - Could not update the Bootloader on my Windows 8.1 32 bit PC.
Could finally update the bootlpder on my Win 7 64 bit Notebook


#7

I was fighting through the same issue my my Spider a few days ago and came across a post that suggested using a different Gadgeteer cable between the board and power. It worked for me after trying three different cables.


#8

I once had an similar issue.
The cause was that I had an USB serial module to my MedusaMini connected at the same time.
By this FEZConfig could not find the Cobra II in booter mode.
I’d guess it was talking to the Medusa.
SO if you have any other USB Serial device connected to your computer this might be the reason it is not working.


#9

@ njbuch - We were finally able to get the code 10 error a few others have reported, but only sometimes, only on a USB 3 port, and only on one computer. Once we switched to USB 2, the error has yet to present itself. I would try to find a USB 2 port to use if you aren’t already as we don’t currently have a fix for the USB 3 issue we saw.


#10

@ John - thanks for looking into this. Will dust off an old PC.


#11

I’ve been experiencing problems here too and @ Andre.m suggested that the USB_DP should be powered too, not just rely on the power from the USB port. I haven’t tried it on my Spider yet, but seeing as I has Windows 8.1, I let you know once I have.


#12

UPDATE: Took the old Win7 Lenovo T60 32bit laptop, dusted it off, and installed the new SDK. Updating the Spider was going smoothly no problems with tinybooter or firmware, directly from FEZConfig. :slight_smile:

Maybe a version check built into the FEZ Config app would be helpful to shave some hours of frustration. :wink: