Main Site Documentation

Update Spider fw issues


#1

hi,
I have new FEZ main board, iwant to update it,
I use the new tool
https://www.ghielectronics.com/docs/127/firmware-tinyclr-update
but after I updates (the tool read the version and says it is uo to date)
my network doesn’t work.
I tried to use both the built-in ethernet, and ENC28 ethernet -they are both don’t reply.

before update- my network replied pings.
only after update, it stopped.

I updated via advanced->FEZ spider,
and tried also the default tab of “update firmware”.


#2

Check Network Configuration. I had to “reapply” MAC address on my spider after the update.
MAC address is on the sticker on your Spider’s EMX module.


#3

maybe that is the problem, but don’t understand the syntax of the mac.
in the tool written: 0-21-3-0-0-2.
on the board: 0021038046DD,
how should I write right to update?


#4

@ Chaya - Like this:

00-21-03-80-46-DD


#5

@ Architect- try tp u[date, but the gadgeteer doesn’t answer,
I get: “Destination host unreachable”.
.
maybe it something in the wifi pass phrase or something else, even if I don’t use it ?


#6

I have upgraded my spider with R3, reset MAC and web client code works.

Does your code deploys ok? Do you have display connected?


#7

hi,
I solved it,
I found out, I don’t have to change the MAC address.
the flow I do:
update the network settings.
reboot CLR.
deploy my HEX file
and it brings ping.

(in past- it brought ping without depolyment…)