Main Site Documentation

Unread posts feature does not seem to be working


#1

For the past few days the unread posts feature does not seem to be working for me. It used to work great, but now it doesn’t.

One or two topics will be marked as unread, but I can see by the last post info that many more have had recent posts that I have not read.


#2

Yesterday it started working again, but today it’s not.

If I go to Forum / Unread Messages, it tells me there are none, but when I look at the Last Post column there are dozens of unread messages.


#3

They may not show immediately but they should in few minutes. I think if you log out then log in then they all show immediately.


#4

Thanks Gus. Logging out, and then logging in worked.


#5

Gus, sorry to keep bugging you about this, but it definitely is not working correctly. Even if I logout and log back in. Here is a screen shot just taken a few seconds ago that shows the sort order is also not working correctly. Notice that the Glide post by Joshua occurs after the older RLP post by you.

This was working greate a couple of days ago, but then strange things started happening :frowning:


#6

as a formerly vocal person who had this kind of issue, I have to say that it is more than likely something local to you. I haven’t seen this kind of issue in months, but previously i had it a lot… Browser update recently?


#7

Sorry, dumb me :-[

I just realized that there is NO sorting on this page!
But I swear the normal unread messages is not working correctly. I can leave the site for a couple of hours, and then return, and it reports no new messages. However, if I scan the posts there are LOTS of new messages. If I logout and login again it partially helps, but still does not report all the new posts.


#8

Brett, I have been using the forum from home and from work. At home I use IE8 and at work I use IE7. It worked correctly on both browsers a few days ago, but now does not seem to work correctly on either browser. I may have had a Windows update recently, which I guess could have affected it??


#9

if it wasn’t working reliably across both of your machines, then the chances are its not a browser issue…

Your scenario just got weirder. ???

I’ve personally always had a dislike of AJAX code that populates things like the forum unread list, but that’s probably more because i don’t understand enough :slight_smile: I’d want to do that in server-side but thats not the way this forum code works. Perhaps its related to timeouts; I see some weird things occasionally when I can load the shell of the unread list page, but the actual list never returns (the AJAX call seems to fail and not report an error)