Main Site Documentation

Unknown Devices


#1

Hi, I am new to .NET Gadgeteer platform. After I followed the instructions in https://www.ghielectronics.com/support/.net-micro-framework and wrote a dummy program, I tried to connect the .NET Gadgeteer modules to the computer, but I got the error as shown in the picture. I repaired the USB driver (X64), but the error remains.

The modules consist of FEC Spider 1.0 mainboard, USB Client DP, WIFI-RS21 and a light sensor.

Can somebody help me please?


#2

@ gzsimonfbi

What OS do you have?

Are you plugging your device into a USB 3 port? If so, try a different non USB 3 port.


#3

@ Aron - I did plug the devices into USB 2.0 ports. I am using windows 7 currently. Thank you for the reply.


#4

@ Aron - And I have also tried to update the driver automatically and manually selecting from .\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers. It did not work.


#5

How are you powering the board and are you running any kind of virtual machine?


#6

@ Aron - I am using GHI USB Client DP to support the power of mainboard FEZ Spider 1.0. And I do have VMware Workstation installed on the laptop. But when I connected the modules, no VM was running.


#7

Welcome to the forum

Until you can get the driver installed and the device successfully recognized, you can’t proceed to deploy code to the device - so we need to get that working. Can you show us a picture of Device Manager and expand out the details on the unknown device? I would also try to put the device in loader mode (see the card that came with your Spider on setting the switches) and see what appears in Device Manager.

And once we get past this, you should make sure you update the firmware !


#8

@ Brett - Sorry, I do not have modules with me now. I will try to post the picture as soon as possible.


#9

@ andre.m - Sorry, only from the USB


#10

I ordered some modules last night and the new ones are totally fine. Thank you, guys.


#11

@ gzsimonfbi -

In case the older one still doesn’t work, try to reflash it.

https://www.ghielectronics.com/docs/54/firmware-update-emx

Or use Spider Updater / EMX Updater, it is easier.
https://www.ghielectronics.com/support/.net-micro-framework
In section 4 - (Legacy versions of our firmware updaters are available here)

Please note that FEZ config took won’t work in your case.