Unable to upgrade FEZ Pico FW to latest

Hi All,

I have just purchased two Boards from GHI, FEZ Duino and FEZ Pico.
I have followed instructions on Getting Started and installed MS VS 2022 community on my PC and installed the TinyCLR OS Project Extension.

I have tested a code that I copied from GHI site to test the FEZ Pico and Blink the onboard LED on PA8 and I was NOT able to make it blink, I got an Error that I have not had the correct version installed for the board at hand.

I downloaded the TinyCLR Config and connected to my FEZ Pico and saw that the Firmware is OLD , and I wanted to update it tom latest - But with no luck.
I was able to connect the board and see the green message say “connected” but…every version I tried to upgrade it to - I was getting an Error that the board is not connected and I have connected it back and tried again and with the same error again.
I even tried and with no luck at all.

I would like to upgrade the FEZ Pico to the latest that I will be able to program it from MS VS 2022 and intended.
I did managed to reinstall the Extension for VS in version 2.1 to meet the FW on the board and was able to program it - But I do want to upgrade the FW version that I will have the ability to program more boards in the IDE that uses Most recent FW and also the latest.

Please assist with upgrading the FW for my FEZ Pico that it will be running on

Looks like you are doing everything correctly. I am guessing power maybe the issue.

Have you tried connecting the board directly to the PC, without a USB hub? Have you tried using a powered USB hub. Have you tried providing power to the Duino and try to update? Have you tried anther PC?

Welcome to the community.

Thanks so much Gus, Happy to be here - thank you!

That did the job - I have used another PC and I was able to upgrade to the latest. Not sure why it did not want to ONLY flash the FW but was able to program the board - I always use short (25cm-30cm) and high quality USB cables to try and avoid that - But, it seems like the FRONT USB was not enough for the job. I think that it might have worked with the BACK (on-Board) USB if I had tried that as well.

It is now upgraded to the latest version and I reinstalled the TinyCLR OS Extension to the latest on MS VS 2022 and I was able to program it without any issues.

Thanks for the quick and prompt answer.