Main Site Documentation

Unable to deploy NETMF 4.2 project


#1

Hi,
I’ve tried to deploy a project in .Net micro framework 4.2 and it failed with the following message:
“Cannot deploy the base assembly ‘mscorlib’, or any of his satellite assemblies, to device - USB:Gadgeteer twice. Assembly ‘mscorlib’ on the device has version or 1 4.1.2821.0, while the program is trying to deploy version 4.2.0.0”

Microsoft .NET Micro Framework 4.2 QFE2 SDK and GHI NETMF v4.2 are installed on my computer.
any suggestion?

(Btw, I’ve tried to deploy the same code in 4.1 framework and it’s deployed successfully)

Thanks,
Judith.


#2

Hi Judith

You need to update the firmware on the board to 4.2


#3

@ Judith - What is your board ?

Version 1.4.xxxxx seems to be an old old one…Depending on the board, you should also not be able to upgrade you device…


#4

Thanks.
It’s work after running FEZSpider Firmware Updater.

thanks,
Judith.