Unable to debug on Panda II

I’ve a project that did work well for months. Starting from yesterday, every time I run debug using F5 the debugger doesn’t attach anything. After a lot of time, it exits, or worse I may stop them. The breakpoint on the first code line is never reached or executed. If I try to pause it, it responds that the debugger is still trying to attach the process.

If I open ad other program and run it, everything works, so the Panda is ok and my environment too.

Any idea?


Drop all your references & re-add them. Also, make sure you’re firmware is up-to-date.

Tried to remove and re-add, still nothing.
Firmware is not changed, the project did work until yesterday :frowning: And the second project, really similar to first, is debugging well…

Are you running both projects on the same Hydra? It sounds like you have a tight loop in ProgramStarted. Make sure you have no loops there. You should be using GT.Timer to offload any code that does anything more than initialization. If these are actually different Hydra’s. Then erase the firmware on the problem one and re-apply so that the blocking program is removed.

Have you made any changes to the program since the last time you ran it? If you have try to return the program to the original state that it worked in and see if that will help. I do not remember what it was or which board/system I worked on but I had the issue where a certain line of code somehow prevented the debugger from working or deploying but I would not get any errors.

This makes me crazy
I’ve removed classes from my project, until I find that if I have this line

       public Decimal Value;

in this class

 class Sample
        public ProbeTypes ProbeType;
        public Units Unit;
        public DateTime TimestampUTC;
       public Decimal Value;


the program is not loaded on the Panda, and debug doesn’t start!

Any idea??


“The number type decimalis not available in the .NET Micro Framework”…

why the compiler and VS validate it? :frowning:

Any suggestion to the best data type to handle measurements from sensors?