Main Site Documentation

UCM Dev Board Rev E with UCM 5550 with WiFi


#1

I just received my UCM Dev Board Rev E with UCM 5550 with WiFi and 7 inch display.

I cannot connect to my board. The USB port seems OK but TinyCLR Config does not
see it.

I looked for some documentation on the Dev board on how to enter boot mode but could not find anything. (I am terrible at searches)

UC5550_USBUC5550_USB_1UC5550_USB_2

HELP- No rush required

Thanks


#2

If you click on the “Please select a device”, does anything show in the list?


#3

Also, check the USB cable.


#4

Dave and John.
I have done both and tried different USB ports on my PC.

I can ping and receive the ‘Pinging… TinyCLR’ response when using FEZ Config
but not when using TinyCLR Config (All menue items are grayed out).

However the UC5550 driver (WinUsb), shows Device not migrated.

I have removed and reinstalled TinyCLR Config Setup v0.11.0.msi.
Yes, I rebooted my PC between remove and reinstall.

I do not know what OS is installed on the UC5550 as received and did not want
to change anything. I wanted to ask GHI if the TinyCLR firmware changes if using
a UC5550 with/without WiFi.


#5

Don’t use anything NETMF with TinyCLR. If FEZ Config sees the device, that means something is cached on your computer. Uninstall the device in the Device Manager, deleting the driver software if prompted, then restart the device.

The same firmware is used regardless of whether or not the WiFi module is present. If you wish to reflash the board with the latest software, SYS A on the dev board will put the module into the ST DFU mode allowing you to reflash the GHI Bootloader. http://docs.ghielectronics.com/software/tinyclr/loaders/stm32-bootloader.html has information on that.


#6

Thank you for the info! Appreciated…


#7

Just erase that current firmware and load latest TinyCLR firmware.


#8

I have exactly the same hardware and the same problem.
In my Device Manager I can see the UC5550, but the TinyCLR Config does not show the device.

I used the latest version:

  • TinyCLR Config V1.0.0-preview1
  • I have also successful reflash the Bootloader with DfuSe - UC5550 Bootloader v2.0.4.dfu

Any idea?


#9

What version of Windows are you on?


#10

I am using Windows 10 Pro.
When I open FEZ Config, I can see my device as “UC5550_UC5550” and it show me the devices firmware version of: 4.3.8.1.
So maybe the NETMF is installed? How can I delete NETMF?


#11

You shouldn’t use FEZ Config with the UC5550, make sure to use TinyCLR Config. You can go into the Loader tab to reload the TinyCLR firmware if needed.


#12

It was just for Information that FEZ Config can find the device, but TinyCLR Config can’t find the device.
How can I reload the TinyCLR Firmware when TinyCLR Config can’t find the device?


#13

I’d start by uninstalling the device from the Device Manager, checking the box to remove the files if it appears. Then hold down SYS B and go to the Loader tab in TinyCLR Config, a COM port should be present. You can connect to it and erase, then load, the firmware.


#14

Thank you for help.
After some failed attempts I found the problem. The GHI Bootloader Interface (COM15) was also used by an other virtual COM Port (N-Port).

After doing this steps, I found the device in VisualStudio:

  • Connect USB Cable
  • Hold SYS B and press RESET for one second.
  • After that, in Device Manager - COM & LPT - GHI Bootloader Interface (COM15) was present.
  • Then in TinyCLR Config (Loader-Tab) I selected COM-Port (COM15)
  • I executed “Update to Latest”
  • I press “Run” button.
  • Released SYS B button.

Then in my Visual-Studio Project - Properties - TinyCLR OS - Device - I was able to select Device UC5550_UC5550.
So it works now… thanks for help :slight_smile: