Main Site Documentation

Tutorials down today?


#1

I’m getting a “500 Internal Server Error” for all NETMF tutorial pages…?

-Scott


#2

I have tried several all work fine.Which are not working for you?


#3

Every link I try gives the error. Tried using a different computer - no luck. Might be an issue with firewall at work?

-Scott


#4

It is possible.


#5

Here’s what I get from any link I click on in the NETMF tutorial section:


A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:
(SQL query hidden)
from within function “User::addToDatabase”. MySQL returned error “1048: Column ‘user_email’ cannot be null (localhost)”.


I seem to recall viewing these from work before, so this seems a bit weird.

-Scott


#6

Sounds like like your user information (email) got corrupted. I am sure somebody (Josh) from GHI will look into that.


#7

It should work now so keep this thread updated.


#8

Okay, it didn’t work, so I tried logging out on my other computer. Once logged out, the tutorials worked fine.

However, I could not log back in from the wiki.tinyclr.com page!!! I got a similar SQL error saying the username cannot be null. When I went to the tinyclr.com page and tried the login in the menu bar, it worked fine. BUT - I was once again unable to view any tutorials!

So it appears that my account is somehow corrupt. It must have happened when I updated my avatar earlier today.

Hope you can help!

Thanks,

Scott


#9

It’s worth another try.


#10

It’s working now - thanks!

Scott