Tunes module doesn't play music

Hi, i hook up the tunes module that i bought the last year to Fez Raptor 18 socket and use the same code showed as a sample in this thread:

But nothing happened… Does it mean the module is dead or something goes wrong with pwm on 18 socket?

This is the first time i try the Raptor, i bought it the last year too. Before i start i checked the Raptor with FEZ Config and the programm accepted the loader and everything is up to date. I am using th 4.3.6.

Do you have any ideas guys?

Can you try a different cable and a different socket please?

@ Gus -
I,ve tried three cables. How to try another socket on Raptor when desiner only allows me too choose 18? Also i set the tunes module to Cerbuino bee and tried to load the same sample code, but the same result - no success.

Contact us directly worth a link to this post please and wet will take care of this.

1 Like

@ Alex Bilityuk - There were some issues in Tunes that have been fixed since the 2014 R5 SDK. Can you try the below code on your FEZ Raptor?

void ProgramStarted() {, 250);

1 Like

@ John -
Here you go!!! Thank you!!! That did the trick :clap:
What was the matter with code sample posted in the link i provided?

@ Alex Bilityuk - Try:

void ProgramStarted() {
    var melody = new Gadgeteer.Modules.GHIElectronics.Tunes.Melody();

    melody.Add(500, 100);
    melody.Add(600, 100);
    melody.Add(700, 100);;

1 Like

@ John -
Thank you!!!