Main Site Documentation

Troubleshooting Hydra install


#1

I’m working on a Win7 VM from a UniBody MacBook.
I’ve had a Panda II for a while and ordered a Hydra and touchscreen when they came out.
I installed the first round of drivers when I got the Hydra and used the SD card method to wipe the board. I quickly ran in to the bug the others had where the ‘reboot to deploy’ failed.

This morning I downloaded the new drivers,
uninstalled everything from my VM,
installed the new packages
updated the Hydra firmware using the SD boot.bin to wipe it, then the Firmware update tool. That runs fine. The T35 says
TinyBooter v4.1.2821.0
FEZ_Hydra Build Date:
Feb 23 2012 14:02:26
Waiting
Device manager sees the GHI .NET Micro Framework Debugging Interface. The FEZ Hydra shows up in Devices & Printers.

When I try to deploy a basic solution Visual Studio hangs or says "Device not found or cannot be opened - USB:Gadgeteer"
The MFDeploy tool hangs until i disconnect the board.

I’ve rebooted the VM, disconnected and reconnected the Hydra, reflashed it and I continue to get the same results.

What am I doing wrong?


#2

Hello and welcome to the community. I got an email from Mike and I think he has similar problem, Mike?

Hydra had a bug before but that was fixes so older post do not apply anymore. Still, Mike was able to use hydra fine on multiple machines but not on VM, Mike? There maybe another bug.

Do you have another machine you can try hydra on?


#3

I can take it to work Monday and set it up on my desktop there.


#4

At the present time, I am unable to get the Hydra working on an IMac running a Window 7 64Bit Fusion VM.

I am now in the process of setting up a real Windows 7 machine on the IMac using Bootcamp.

After testing on the real machine, I am going to run the real disk partition under a VM, which is a Fusion feature, and see if that works.

There is also the possibility that the problem could be related to the VMWare drivers that run in the virtual machine. I will test this by removing the VMWare tools.

@ Mike: What is the speed of your Macbook’s processor? We need to determine if this is an issue of processor speed or Fusion environment.

I also have a older Macbook, with an older version of Fusion installed. I will also be testing on this Macbook. If we get lucky, the problem will show up, and I can ship the Macbook to GHI.

I am able to run all of the other GHI boards, including the Spider, under a virtual machine on the IMac.


#5

2GHz Core 2 duo 4gb ram
Fusion version 4.1.1(536026)
2 processor cores and 2044mb ram allocated. It’s running from a partition on the disk. (Can you setup bootcamp to use an existing drive?)
I’m using 30gb of the 50gb partition so I don’t have a problem making a snapshot of the drive and posting it somewhere.


#6

when you use bootcamp to setup windows, a partition is setup for windows. after you install windows, fusion should be able to see the partition and run it.

I think the hydra will run with native windows (bootcamp), but fail when the bootcamp partition is run under fusion. I will know more tomorrow. I am setting up bootcamp now.


#7

I brought my package to work with me.
I loaded the .Net Micro Framework 4.1 and the GHI NETMF v4.1 and .NET Gadgeteer Package, neither have been setup on this machine before.
Windows recognized the Hydra right away.
MFDeploy responds
Pinging… TinyBooter
Bootloader build info: Copyright © GHI Electronics, LLC
When I try to deploy a new Gadgeteer project VS still hangs.

Both computers have VS2010 Professional with SP1


#8

You board doesn’t have the firmware on it. Ping should return TinyCLR.


#9

I launched the FEZHydraMainboardUpdater.exe and it can’t find the board. I know I ran that at home and selected the ER_CONFIG and ER_FLASH. I did have to hit the reset button twice for the Next button to show up, and after I clicked Next the dialog closed.
If I can find a SD card here at work I’ll try the whole process again.


#10

No need for SD. You have TinyBooter loader. You only need to select the firmware files and click “deploy” on MFDeploy. See this please http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra


#11

Looks like that worked. I thought the FEZHydraMainboardUpdater was supposed to deploy those files?


#12

Mike

I setup a Hydra Windows development environment on a 2006/7 Macbook using Fusion 3 and I seem to be experiencing the problem.

I still have to do a few verification steps, but I think I have the problem captured. If all goes well, I will shipping the Macbook to GHI later in the week.

Then, depending upon GHI priorities, we should have a solution in a timely manner. :smiley:

BTW, the Hydra worked fine running Windows in a native mode on a 3.4GHZ IMac. The problem is associated with running in a virtual environment.


#13

I had the Hydra working all day at work. Come home and plug it in to my VM and I get the same result as last night. MFDeploy and VS don’t see the board.


#14

Ok so now you know all is good beside the knows USB problem when using VM.

Mike is sending us something so this fix will not take long.