Trouble upgrading to Bootloader v2 (G120E)

I’ve been attempting to follow the setup instructions for the G120E Dev Board here but am having some issues upgrading to Bootloader v2 that I’d appreciate some pointers on.

I get as far as step 8 in this (sending the file by XMODEM), then Tera Term either gets stuck at 128 bytes transfered, 0.9% progress or seems to abort the process entirely.

I’ve tried to use the COM1 port instead (as it is noted that The USB interface on Version 1.0 doesn't always work on Windows 7 and newer operating systems. Use the serial interface instead.), but am unable to get any communication when plugged into to COM1. (I have tried pulling the MODE pin down to ground while resetting as described in the documentation, but this seems to have no effect.)

Any suggestions would be greatly appreciated!

Welcome to the community.

Are you trying to load TinyCLR 1.0? In case you have missed the recent announcements, we are about to announce TinyCLR 2.0 and the recommended path for G120 is NETMF.

So, if you are going to use G120 then NETMF is what you need, which does not need loader v2. And if you are interested in TinyCLR then stay tuned for announcements coming shortly, or contact us directly if you have an immediate commercial need to get early access.

Hi JRVeale, welcome to the community!!

I’ve just spoken to JRVeale on the phone and it turns out the “1K” option in Tera Term wasn’t checked. Seems to work now. I need to make the docs a little clearer as it seems that too many people miss this step – sorry about that.

1 Like

I’m assuming loader v2 won’t be a problem for TinyCLR 2.0? I’ve just managed to get loader v2 running (thanks to Joel’s help on the phone) - I’d forgotten somehow to check the 1K option in Tera Term’s XMODEM dialog…

It was very clear on the docs, the fault was mine for skim-reading something I thought I remembered better than I did!


You can continue to experiment with TinyCLR 1.0 with the understanding that much is changing soon.

1 Like