Main Site Documentation

Trouble updating firmware


#1

Ive erased the chipwork with “up select down reset” and the screen has faded to white, but Im having trouble getting firmware back onto the device. Ive also tried the same thing from the command line but I get the error message “com3 not found” im absolutely stumped. Thanks in advance


#2

my apologies i found the solution after searching the forum, thankyou for your help :slight_smile:


#3

How did you fix that problem? Can you help us to share the way you fixed please?


#4

I just got my ChipworkX Development System yesterday and was anxious to try it out. After installing the “GHI NETMF v4.1 and .NET Gadgeteer Package”, it seemed like I should update the firmware. (I shouldn’t have!) I carefully followed the instructions, but I ended up with the white screen described above. After searching through the forums, it became apparent that I needed to follow the instructions in the ChipworkX User Manual (section 6.1 Emergency Bootstrap access). I was able to get past the white screen and update the firmware, but it doesn’t seem to be acting quite right. Unfortunately I have so little experience with this device, I don’t know what its normal behavior is. Before attempting the firmware update I noticed there was some kind of graphical interface displayed, but now I seem to have lost it. How can I restore the ChipworkX Development System to its original (factory default) behavior? Thanks!

I’ve attached a screen shot of the current MFDeploy Device Capabilities output.


#5

Output looks good. Why do you think it is not updated correctly?

…and welcome to the community.


#6

I haven’t seen the initial graphical display on the device since I updated the firmware. I’ve tried running the example in the Getting Started guide, but when I get to the part where you add the “GHIElectronics.NETMMF.IO” assembly, nothing is listed. Also, it seems like whenever I disconnect the device from my computer and then reconnect, I get the white screen. It does however seems to eventually go back to the initial text display. Again, I’m so new to this I don’t know what is normal, it just seems like something’s not quite right.

How can I recover the initial graphical display I saw when I first connected the device? I didn’t even get a chance to check out what it does.

Thanks!


#7

This is normal. You erased the demo. You can load anything you want, including the demo. I suggest you start with simple programs instead of using the demo. Search the wiki for “graphical”

[quote]I’ve tried running the example in the Getting Started guide, but when I get to the part where you add the “GHIElectronics.NETMMF.IO” assembly, nothing is listed.
[/quote]
This is installation problem and unrelated to firmware update.


#8

I kind of figured the initial graphical interface was a some kind of demo program–I just regret I didn’t check it out while I still had it available. I didn’t attempt to update the firmware until I saw the problem with the missing “GHIElectronics.NETMMF.IO” assembly. I thought it might be related to the firmware, so I tried updating it. I feel much better now, and I think I can figure out the installation problem with the missing assembly. Thank you for all your help! :wink: