Main Site Documentation

Trouble Updating FEZ Hydra Firmware


#1

Hello,

I am following the steps here to update the Firmware for a FEZ Hydra:
http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra

Everything works until I run MFDeploy 4.1. MFDeploy sees the FEZ Hydra as a USB device, but I can’t deploy the firmware or ping the device. I tried on 2 seperate computers and I am getting the same problem.

The TinyBooter seems to be loading just fine.

Any ideas?

Thanks in advance,
-Mike


#2

Have you tried to put it into TinyBooter mode with a button in socket 14?


#3

What do you see in device manager?


#4

I did try the button in socket 14.

I am attaching what I see in the Device Manager and on the LCD screen.

The device should up as a com3 (GPS camera) during the erase process.

-Mike


#5

You have loaded tinybooter successfully. Now load the firmware using mfdeploy.

Can you ping from mfdeploy?


#6

Hi Gus,

I cannot ping from MFDeploy.

-Mike


#7

Ok finally we have another confirmation of this problem the other mike is having. There seem to be a bug in USB that we are not able to reproduce here!

What do we need to do to repro here? We tried many pcs and many laptops. All worked fine!


#8

@ Mike

Is the USB connected direct ? I mean there is no hub ?

Can you use another cable between the power module and Hydra, preferrably a shorter one.


#9

Mike H:

What is the processor speed of the PC you are using?


#10

Rajesh: I was connecting directly to the computer with a very short USB cable (about 6 inches long). No hubs – direct connect.

The CPU on both boxes is an Intel Core i7. One was a mobile chip running at 2.5GHz and the other is a 2600K running at 3.4GHz.

Both boxes are running Windows 7 x64 with SP1.

-Mike


#11

I kept digging at this and was able to replicate the behaviour 2 times over serveral tests. When I ran into the issue the boot was fine and the LCD displayed the correct firmware numbers and the 'waiting for … ’ message. However I was not able to ping from MFDeploy or deploy from Visual Sudio.

I went through the entire cycle of erase. Still MFDeploy could not ping.

Restarting the Windows (Win7 64Bit) puts things in order. I was able to ping and flash the firmware.

Please try a restart to see if it helps.

It looks like there is a glitch with the USB firmware or the driver.

The behaviour can be reproduced by repeating

[italic]**Initial state : I had the original firmware that was on the Hydra when it was shipped to me on 11/09/2011. This was the very first firmware.

I did connect the Hydra to the computer multiple time prior to erasing and updating the new firmware.
[/italic]

1.Open Visual Studio
2.Create a simple app
3.Deploy/Debug
4.Stop debugging
5.Reset Hydra
6.Let the deployed app. run for a while
7.Deploy/Debug from Visual Studio
8.Stop debugging
9.Reset Hydra
10.Let the deployed app. run for a while
11.Unplug Hydra
12.Wait a while
13.Close Visual Studio
14.Ping from MFDeploy

You may have to repeat these steps multiple times.


#12

Hi Rajesh,

I did a cold boot and that did the trick. I also ensured that the USB cable was very short (less than 6 inches) and attached directly to the mother/logic board of the computer.

Thanks for the help everyone!

-Mike