TinyClr - touch exception

Testing our new motherboard with uc5550. So far everything seems OK except the touch.
Touch worked perfectly using the UCM dev board.

I am using the FT5xx6Controller. On touch, I get the following exception:

The trace form the output window:

Can this give a hint on what is wrong with the new motherboard.?

This is the schematic of the LCD display header on the new motherboard:

Which seems to be identical to the UCM dev board

is it same display or different display? It may need pull up resistor on SDA and SCL.

It is the same display. What does the out trace of the exception show ?

do you have the interrupt pin connected?
Do you have pull up resistors on I2C?

the signal LCD_IO (GPIO B) is connected (same as UD700 and UCM dev). There is another additional device on the SCL/SDA lines, no pull up.

I2C does not work without pull up resistors, 2.2K each.

1 Like

OK. I’ll have them added to prototype boards. (After reveiwing further, I found them on the ucm dev schematics)

We have added the pullups to the SDA and SCL. Still the same problem. I get an exception in the Interrupt routine. The output trace of the unhandled exception was included above. Does that trace show anything about what caused the exception ?

Multiple interrupts with the same port #?

try with other I2C slave device if you have any, very rarely but take a look if SDA and SCL are swapped.

The pullups were installed incorrectly. When corrected, it all works OK

1 Like

You owe us some beer then :wink:

OK, but root beer