TinyCLR startup issues

I’m taking my first dive into TinyCLR and have a few startup issues. I’m using a UC2550 on a breakout board. I’ve got the USB 5V on the board driving a regulator for the 3.3V supply. Both the 3.3V and USB5V red LEDs light up when I plug in the USB. I’ve tried it with the USB5V jumpered to the 5V on the board and without the jumper. A UC2550 does show up in the device manager when I plug it in but neither Visual Studio 2017 or TinyCLRConfig see anything. I didn’t see any step in the installation where I was supposed to load USB drivers. Did I miss that?

The other issue is I don’t seem to be able to install any libraries. GHIElectronics.TinyCLR.Core loaded without my doing anything but when I try to install anything else, like GHIElectronics.TinyCLR.Devices, I get this error

Unable to load the service index for source http://packagesource.
An error occurred while sending the request.
The remote name could not be resolved: ‘packagesource’

As usual, any help will be greatly appreciated.

Looks OK, but maybe have you tried updating TinyCLR firmware using
Does putting in into DFU Mode work?

Also looks like your Nuget package source is wrong
Check you have not done a copy and paste error into Package Source Setup
Go into NuGet manager in VS and hit the Setup COG

Looks like you have one in there that the URL is actually ‘http://packagesource’ which is not the correct url.
GHI post their release version to standard NuGet feed

1 Like

@PTSS You’re my new best friend. I thought I’d post a little more detail about how your suggestions made it easy to fix my startup issues in case it might help someone else in the future.

For the NuGet issue you said:

Here’s what my Project->Manage NuGet packages… and then clicking on the settings gear gives me

The URL you refer to is there but somehow the package source option was checked and was getting in the way. All I had to do was uncheck the package source option as shown above and I can download the packages.

For the issue about neither Visual Studio or TinyCLR Config not being able to see the UC2550, I hadn’t done all the necessary steps. The “Getting started with TinyCLR” page does say “Instructions for installing the bootloader and firmware are provided on the documentation page for each device.” I guess it would have been better for a slow learner like me if that sentence had been in bold 36 point font and provided a link to all the device pages.

Thanks for your help, I’m off and running with TinyCLR now.