Main Site Documentation

TinyCLR Failed connecting UC5550


#21

Sys A: DFU mode
Sys B: Bootloader mode
Sys D: switch to serial mode.

Need Bootloader through USB mode: only SysB
Need Bootloader through Serial mode: SysB + SysD
What Gus advised is Bootloader through USB mode. You need switch back to USB Client lable and need only Sys B.


#22

Great. These tips are tricky without document.


#23

Please go back to the steps I provided and follow them to the exact. We want to get your board working and then we will happily explain everything and update the docs as needed.


#24

I followed Dat’s tips:
“Sys A: DFU mode”
“Sys B: Bootloader mode”
“Sys D: switch to serial mode.”

I bought two UC5550 UCM boards at the same order from MOUSER. One board has WIFI and the other without WIFI.

The UCM without WIFI could be successfully uploaded to boot loader V2.0.5 and its USB interface UC5550_UC5550 shows on Debug side.

Capture%20TinyCLR%20205

However, the UCM with WIFI remained at V2.0.4 after successful “Update to Latest” even re-tried several times.
Capture%20TinyCLR%20204

I tried to upload the boot loader with DfuSeDemo with file “UC5550 Bootloader v2.0.5.dfu” and "Upload successful. However, the boot loader version keeps on V2.0.4.

Best regards,
Kok Hung


#25

The update to lastest button will update the firmware and not the loader. You need ST DFU tools to update the loader.

I am glad we were able to help you. Please let us know if you need further assistance.


#26

Hi Gus,
Please see my last image that showed the successful upload of the ver.2.0.5 dfu file with DfuSeDemo.
After that i went back to TinyCLR Config loader tab and found the boot loader version is still v2.0.4
Best regards,
Kok Hung


#27

Upload is the wrong section. You need Upgrade. Which means you have corrupted your DFU file. Please download the file again and use the Upgrade section in the tool.


#28

HI Gus,

Press Sys A and Reset hence enter into DFU Mode.
Open DfusSe Demo. In the “Upgrade or Verify Action” group panel, click “Choose” button to select “UC5550 Bootloader v2.0.5.dfu” file. Check “Verify …” and “Optimize…” check boxes and click “Upgrade” button. It successfully passed through Erasing, Uploading, Verifying steps. I seems the upgrade was completed successfully.

Press Sys B and Reset hence enter into Bootloader mode.
Go back to TinyCLR and found that the boot loader version is still V2.0.4 without change.

Capture%20TinyCLR%20Loader

Would Gus please advise the next step.

Kok Hung.


#29

Download the file again from the website. You have corrupted the file when you did the wrong step last time.


#30

Gus,
You meant the file “UC5550 Bootloader v2.0.5.dfu”?
Downloaded the file and retried in DfuSe Demo. But nothing new. The boot loader is still V2.0.4

Kok Hung


#31

I am sure it is the file. Please delete the old file completely and try again. Which button did you click to load the new loader file?


#32

Hi Gus,

Download the dfu file again with Microsoft Edge and upgrade again with DfuSe Demo. The upgrade process goes faster than the previous file. The dfu file is different from the previous.

Go back to TinyCLR and both two UCM could automatically detected to V2.0.5.

Thank Gus and Dat for your valuable tips and patient coaching in this matter.


#33

Glad it finally worked for you