Main Site Documentation

TinyBoot update failed, device is now stuck!


#1

Hello,

Following one of the TinyBoot updates (which failed), the device is stuck in some mode, where it

Doesn’t appear as USB.
Doesn’t connect, doesnt’ respond.
Can’t do any update anymore.
Complains about Bootloader driver.

My drivers are fine, because I have other boards, that are working just fine.
Tried two different machines.

How can I get the device back to normal ??

Thanks
M


#2

I’m assuming it’s the EMX device that the other thread is about.

What devices are visible in Device Manager, that it’s complaining about? Can you boot it back into serial bootloader mode so the COM port appears? Then, step through the update with TeraTerm.

There was an EMX driver issue early in Win8 then Win10 days, was there not? Bootloader update reliably works under Win7 though, were any of the multiple machines you tried running Win7 by any chance?


#3

Hello,

Yes, this is correct. It’s same EMX as in other thread :))
There are no USB devices visible.
There is some sort of COM1 device, but it’s there even when USB is not plugged.

I think what happened is that I tried to update TineBoot with version 4.2.5.0, while firmware was selected automatically for 4.2.11.1…
And that’s why it failed in the first place.
But I don’t think I can actually brick the board completely this way ?

When you say booting with serial loader is by shorting pins (instruction appears with TinyBoot update) ?
I tried that and that’s when I get “can’t communicate with serial device” error…(window)

I use Win7, so I doubt that problem is with driver, but I can try to reinstall it… ?

thanks,
M


#4

if you read thru this doc (even though it’s marked obsolete) https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families you’ll see; I’m expecting you should be able to get the serial device to show up no matter what.


#5

@ Brett - hello.

Ok. Little by little it started responding and finally I managed to update it via TeraTerm.
Thank you very much for your help!!