Main Site Documentation

Tiny bootloader on G400


#1

My beta kit also arrived today. Yay! :slight_smile: But like some others I’m also struggling a bit to get the bootloader and firmware loaded. I saw there is another thread about the same subject, but decided to start my own for my questions so as not to cloud the other thread.

I’m a bit confused by this step:

[quote]
Step 2.
You will need to “power-up” or “reset” the board while using a jumper wire from ground to PA11 (Do not hold the pin to ground no longer than 3 seconds - damage to processor may result) to access the Atmel SAM-BA bootloader. There you will see a virtual COM port. Aquire the COM port number.[/quote]

My questions:

  1. Do I need to start sam-ba_2.12.exe before I do this or after.
  2. I see nothing happening when I do this. Is Samba supposed to pick up the serial port automatically or do I need to refresh? Is this perhaps because I first need to install a driver for sam-ba?

Looking forward to hear from you guys that have already done this.


#2

Check to see what is showing under device manager


#3

I have my un-touched G400HDR unwrapped, and when I connect DP module to socket 4 and connect it to a PC, I instantly get the GPS Camera Detect COM port coming up.

As to whether it’s important to start SAM-BA before you do this, it is an ATMEL question. The app needs to see the COM port; perhaps it has logic in it to re-scan, but it’s likely that it won’t, so make the port visible by doing the appropriate reset, then run sam-ba.


#4

Take some of that back. The app sam-ba_2.12.exe is an installer that installs SAM-BA on your machine. Install that.

Then, you open the beta programmer folder, and open the command prompt, and run the command prompt - you never actually run the SAM-BA app.

At the end of that, your device needs a restart, and then the .net debuggable device appears.


#5

Thanks for the advice. I managed at least to get to a point where the Tinybootloader upgrade starts, but it appears to only run up to a point where it erased until 90% and then it just hangs there. I tried several times and always get the same results.


#6

Ok, after rebooting my PC, I got the TinyBootloader programmed as can be verified in Fez Config:

Connecting to device…G400_G400
Loader (TinyBooter) Version: 4.2.10.0
Firmware (TinyCLR) Version: Not available.

But now my next problem is that every time I try to program the firmware, the board tell me “Interrupt occurred while deploying. Updating failed”. I tried several USB ports, and also tried attaching an external power supply to my USB client DP module but it did not help.