Main Site Documentation

The state of SDKs, Drivers, VS integration, etc


#1

Can anyone help paint a current picture of the state of things in the gadgeteer world?

I started using v4.1 where everything was “peachy”. VS 2010 worked great, Wifi worked great, etc. When v4.2 came along, reports of horrifying issues came in (such as RS21 Wifi module doesn’t work, etc). Worse, the designer in VS would not support the gadgeteer. Shortly after, we also had Win 8 come out, VS 2012, and v4.3, and other odd quirks copped up. Things became a big mess. I could link you to SEVERAL posts in this forum.

Anyway, what is the situation now? I’ve been away from this for quite a while, and hoping to jump back in. But I don’t want to update my firmware or try and install things if crap still is not working right.

Main questions are:

  1. Does RS21 Wifi module work without question on v4.2 or 4.3?
  2. Should I use VS 2012 or stick with 2010?
  3. Does the designer work?

#2
  1. It works on 4.2. GHI does not provide 4.3 support yet.
  2. Your choice. I think 2012 is too slow with MF deploys.
  3. Yes. What does not work for you?

#3

one caveat. 4.2 introduced lwIP, and replaced the IP stack that 4.1 and earlier had used. There are still some issues there that haven’t been resolved, but are specific to things like DHCP server responses - you may not see the issue, it is only affecting a small number of people here.

Also worth mentioning is that GHI removed the 4.1 Gadgeteer support when 4.2 came out. So you need old SDKs to get that support if you want to stay where you are, you can’t use the current ones.


#4

Brett, Mike thank you.

Yeah, that was part of my beef with GHI actually, removing 4.1 support before 4.2 was even stable and working for the very modules in production that were current (rs21 being one).

We’ll have to see how my app handles it. Very heavy use of DHCP over Wifi and Ethernet. I built a micro-ASP webserver.


#5

Well someone else put in lwIP not GHI, and GHI just made a decision not to spread their test load over such a wide range of software when they released 4.2- but the 4.1 support in 4.1 is fine and was tested during it’s release (even though I personally wasn’t using Gadgeteer back then I feel comfortable saying that).

Plus, you have to be unlucky to hit this. There’s only a handful of reports here about it, and only a few others in other communities.


#6

And of course we are continuing to improve the software.


#7

Here is a quick update on what I am finding.

Spider v1 with latest firmware
NetMF and Gadgeteer SDK v4.2 installed
VS 2010

Power
Something is wonky with USB Client DP. With the T35 display plugged in along with several other modules, USB alone is not enough power and the device reboots anytime the load is too high. No prob. I plug in a 12v 1A external supply, right? Well… if I have the external supply ALONE plugged in, all is well, device doesn’t reboot. HOWEVER, if I have 12v plugged in AND I connect my USB cable so I can debug the dang thing, it freezes completely, and the T35 screen goes white (all pixels on, washed out).

I cannot dev on this device whatsoever in this condition.

Wifi (RS21)
I’m very impressed that after porting my 4.1 code over to 4.2, using this as a code reference, it works!
https://www.ghielectronics.com/community/forum/topic?id=9411&page=3

I get an IP, and my basic test of retrieving data from a web service passed.

HOWEVER, oddly, NetworkUp never fires! . NetworkDown [em]does [/em]fire. wifi_RS21.IsNetworkUp always reports false even after it IS up and has an IP and is talking.

Looks like internal driver issues to me. Any updates? or, anything I missed? Seems pretty straight forward.