The Reluctant Raptor

I have a Raptor board that refuses to go into bootloader update mode. LDR1 will send it into TinyBooter, but LDR0+LDR1 won’t send it into bootloader mode. I even tried shorting SOM pin 101 to GND and that didn’t do it. Am I doing something wrong here or do I have a reluctant-to-reflash raptor (e.g., an RMA candidate)?

(Firmware flashing worked fine, and I am on the latest firmware - it’s just the bootloader that won’t update and is stuck on

Has this board been updated to use the new GHI G400 Boot Loader?

If not, you will need to update the Boot Loader to use LDR0 and LDR1 pins to enter boot loader.

Try to short SPI1 SCK to Ground? This will force it into Boot Loader mode. Then update the Boot Loader to use the new Boot Loader.

It is not on the latest bootloader - that’s the issue. And LDR0 is not working - so I will try to short PA13/SPI1_SCK (SOM pin 98 ) to GND3 (SOM pin 97 ) and see if that does the trick.

@ mcalsyn - LDR0 only functions once you flash the GHI Bootloader to the board: