Main Site Documentation

The erros in example


#1

I always have the erros in “output window”, when I was trying the example “.NET Gadgeteer Web Service Surveillance Camera” (http://mikedodaro.net/2011/10/15/gadgeteer-web-service-surveillance-camera/#comment-488) :’(

the errors in "output window " as follow:

[b]Invalid native checksum: GHIElectronics.NETMF.Net 0xB7F1767D!=0x310788CC

Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: Gadgeteer.WebServer (2.41.0.0) needs assembly ‘Gadgeteer’ (2.41.0.0)

Assembly: Gadgeteer.WebServer (2.41.0.0) needs assembly ‘System’ (4.1.2821.0)

Assembly: Gadgeteer.WebServer (2.41.0.0) needs assembly ‘System.IO’ (4.1.2821.0)

Assembly: Microsoft.SPOT.Touch (4.1.2821.0) needs assembly ‘Microsoft.SPOT.Graphics’ (4.1.2821.0)

Assembly: Microsoft.SPOT.Touch (4.1.2821.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)

Assembly: GTM.GHIElectronics.Camera (4.1.1.0) needs assembly ‘Gadgeteer’ (2.41.0.0)

Assembly: GTM.GHIElectronics.Camera (4.1.1.0) needs assembly ‘GHIElectronics.NETMF.USBHost’ (4.1.8.0)

Assembly: GTM.GHIElectronics.Camera (4.1.1.0) needs assembly ‘GHIElectronics.NETMF.System’ (4.1.8.0)

Assembly: GTM.GHIElectronics.Camera (4.1.1.0) needs assembly ‘Microsoft.SPOT.Graphics’ (4.1.2821.0)

Assembly: GTM.GHIElectronics.Camera (4.1.1.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)

Assembly: GTM.GHIElectronics.MulticolorLed (4.1.1.0) needs assembly ‘Gadgeteer’ (2.41.0.0)

Assembly: Microsoft.SPOT.Net (4.1.2821.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.1.2821.0)

Assembly: System.Net.Security (4.1.2821.0) needs assembly ‘System’ (4.1.2821.0)

Error: a3000000

Waiting for debug commands…

Das Programm “[20] Micro Framework application: Verwaltet” wurde mit Code 0 (0x0) beendet.[/b]

I don’t know why I always have the misstake.

It seems that I have setup all the neccessay files from “http://www.tinyclr.com/support” and “http://gadgeteer.codeplex.com/releases”.

I have also tried the “Getting Started” in “http://www.ghielectronics.com/downloads/Gadgeteer/Mainboard/Spider_GettingStarted/”, and My “FEZ Spider” works good.

I think my bord is Ok, but why I can’t try the example about “Web service” successuflly,
Does anyone have ein idea?

I use “microsoft visual studio 2010 professional”.


#2

Have you created a “Gadeteer” project to put the code in?
It should have come up with a window showing the hardware you would need to drag the modules used into the project and link them together in the visual designer.

Jas


#3

yes, I have done it.

I tried the example many times…


#4

here is a picture


#5

Hi, I’m quite new to all this myself too. But from the error messages it seems like it cannot find the required dll’s to build the project.

Maybe re-download the .net framework, and the gadgeteer sdk and then re-install. There may have been a problem during the installation.

Also once the latest SDK’s have been installed, maybe update the Spider to the latest firmware in case there is a problem there too.

Jas


#6

Do you have the latest firmware? Look at note #1 when you click reply :slight_smile:


#7

Yes, I think I have the the latest firmware.

I have done everything as show in the “http://www.tinyclr.com/support

I have used the link 2 and link 3 from System preparation.

In addition, I have also set up the “GadgeteerBuilderTemplates-2.41.401.msi” and " GadgeteerCore-2.41.401.msi" from “http://gadgeteer.codeplex.com/releases”.

you can see what I have from picture.


#8

one more picture


#9

I think there is some misunderstanding. You are referring to downloading the SDK which is installed on your PC. From there, you need to update the firmware stored on FEZ. We ship the SDK with a software the will help you in the firmware update process.

The firmware is NOT the application you load from Visual studio C#.

Look in this folder
C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\Firmware Update


#10

I have tried the simpest example in “getting start” successfiily 1 week ago.

I can push the button und get a picture in LCD with camera.

but I am always not successfull, when I tried the example “.NET Gadgeteer Web Service Surveillance Camera”.

I got the errors in “output windows” as show in #1.

I am very confused about it.


#11

Maybe you are confused because you didn’t understand what I am explaining.

Please update your firmware!


#12

Also, no need for 2 threads. You are giving us more work and confusing yourself http://tinyclr.com/forum/21/5733/#/1/msg54377


#13

I am terrible sorry. :-[