Main Site Documentation

Tera Term not working with my FEZ PANDA


#1

Okay so im following the instructions for updating firmware. I used to tera term download that they provided, but i can’t get the select a com. It is greyed out and wont let me click on the serial box. I tried to look at other post but haven’t been able to find anything. again im following the directions to update the firmware it just when i open the tera term for the first time i can’t select a com port because i can’t select the serial box.


#2

Hi Acqualife, welcome.

First thing you probably need to check is what is visible in Device Manager - if the Panda isn’t being recognised then you won’t see the COM port. Attached is the two shots of my Device Manager that shows the two different states you should see. The 2nd is what you’re looking for in the scenario where you need to load firmware. You will also see on the Panda that the onboard LED is dimly lit.

hope that helps.


#3

Also, do yourself a hug favor and download the latest SDK from GHI. It has some easy to use firmware update programs built in. Just run the right program for your processor and follow the directions it gives.


#4

hug favor? haha!


#5

we all like hug favours :slight_smile:


#6

Just updated my Panda today and was impressed by the nice way to do it during SDK installation.

But as a reply to the original question: The serial port is only visible while you are doing the update. So only when you pressed LDR, Reset, and released them in the opposite order a driver for the serial port was installed and only then I could see the serial port. Took me quite some time to figure it out (didn’t want to damge the Panda, so I tried to check everything before touching the board)