Main Site Documentation

T35 Error


#1

I can anyone help (Newbie)

I’m getting error “An unhandled exception of type ‘System.Exception’ occurred in GHI.Premium.Hardware.dll” when creating a new instance of T35 display.

I get this error just from the Program.generated module.

Partial Public Class Program
    Inherits Gadgeteer.Program
    
    Private WithEvents display_T35 As Gadgeteer.Modules.GHIElectronics.Display_T35
    
    Public Shared Sub Main()

        Program.Mainboard = New GHIElectronics.Gadgeteer.FEZSpider()
        Dim p As Program = New Program()
        p.InitializeModules
        p.ProgramStarted
        'Starts Dispatcher
        p.Run
    End Sub
    
    Private Sub InitializeModules()

        Me.display_T35 = New GTM.GHIElectronics.Display_T35(14, 13, 12, 10)
         '//Error here

    End Sub

Fez Spider Dev Kit
EMX version 4.2.10
Micro framework SDK 4.3(RTM)
GHI tools 4.2

Any help would be appreciated. [quote][/quote]


#2

Welcome Steve.

What mainboard are you using?


#3

See Pic


#4

Gotcha …

Is your VS project setup for 4.2 or 4.3?

(Other than this I’ve got nothing)


#5

This may help http://www.ghielectronics.com/docs/43/first-gadgeteer-project


#6
  1. dont edit this file, its auto generated.


Imports Gadgeteer
Imports GTM = Gadgeteer.Modules

Partial Public Class Program 
        Inherits Gadgeteer.Program

    ' GTM.Module definitions
   Private WithEvents display_T35 as Gadgeteer.Modules.GHIElectronics.Display_T35

    Public Shared Sub Main()  
        'Important to initialize the Mainboard first
        Mainboard = New GHIElectronics.Gadgeteer.FEZSpider()

        Dim program As Program = New Program()
        program.InitializeModules()
        program.ProgramStarted()
        program.Run() ' Starts Dispatcher

    End Sub

    Private Sub InitializeModules()
           
        ' Initialize GTM.Modules and event handlers here.		
        display_T35 = New GTM.GHIElectronics.Display_T35(14, 13, 12, 10)

    End Sub
End Class


#7

I don’t

Process

  1. run VS2012
  2. Select new project Gadgeteer(4.2)
  3. Add t35 module, right mouse auto connect modules,
  4. Auto generated code is not changed. No additional code added
  5. hit F5 program crash with above error within auto generated code.

other modules Multi-led,buttons etc all work fine.


#8

What if you do it in C#? I wonder if there is a bug in VB.


#9

Same as VB


#10

pic


#11

When you did this, were other modules connected at the same time? Try just a fresh project with only the T35 connected and see what happens.


#12

Does the same. also tried it on my laptop with same results.


#13

What SDK are you using? Can you post the Firmware version and build date? To get the build date, use the device capabilities option found under the Target Menu.


#14

Info from release notes of installed SDK

GHI NETMF v4.2 SDK Q2: 9:48 AM 5/1/2013
GHI .NET Gadgeteer SDK v1.6.14.0 2:31 PM 5/1/2013
GHI OSHW NETMF SDK v1.0.5 1:40 PM 4/30/2013
GHI Premium 4.2 NETMF SDK v1.0.4 1:40 PM 4/30/2013

T35 is displaying Firmware of 4.2.10.1 on T35

Info from release notes in firmware directory
• EMX v4.2.10.1, TinyBooter v4.2.10.0
• G120 v4.2.10.1, TinyBooter v4.2.10.0
• G400 v4.2.10.1, TinyBooter v4.2.10.0
• GHI Premium NETMF Library v4.2.10.0


#15

In your code, you have all four cables connected. On your board, did you connect the touch cable as well?

If so, can you try removing the touch cable in the designer and physically?


#16

No difference in vb or c#


#17

Not sure is this anything to do with the problem but I noticed that my target framework is set to .net micro framework 4.2. I have changed it to 4.3 but now I get the following deployment error.

Error 1 Cannot deploy the base assembly ‘mscorlib’, or any of his satellite assemblies, to device - USB:EMX twice. Assembly ‘mscorlib’ on the device has version 4.2.0.0, while the program is trying to deploy version 4.3.0.0


#18

There is no 4.3 firmware yet.


#19

Hi,i have the same error when create new project with T35 and run emulator.
Someone have resolve it?